Есть ответ 👍

Вклассе 20 учеников писали диктант по .написать программу подсчета кол-ва 2 3 4 5 получивших за диктант(писать через массива)

278
500
Посмотреть ответы 2

Ответы на вопрос:

Odagio
4,4(63 оценок)

var

  a: array [1..20] of 2..5;   //массив оценок учеников

  i: integer;

  n: array [2..5] of 2..5;   //массив счетчиков оценок

 

begin

  for i: = 2 to 5 do   //обнуляем счетчики оценок

    n[i]: = 0;

  for i: = 1 to 20 do   //вводим оценки учеников и считаем их

  begin

    writeln('введите оценку ', i, '  ученика');

    readln(a[i]);

    if a[i] = 2 then n[2]: = n[2] + 1;

    if a[i] = 3 then n[3]: = n[3] + 1;

    if a[i] = 4 then n[4]: = n[4] + 1;

    if a[i] = 5 then n[5]: = n[5] + 1;

  end;

  for i: = 2 to 5 do

    writeln('количество получивших ', i, ' за диктант равно:   ', n[i]);   {выводим значения счетчиков}

end.

   


1=> 23 1) 1*3=3(1) 2)3*3=9(1) 3)9-1=8(2) 4)8*3=24(1) 5)24-1=23(2) ответ: 11212

Реши свою проблему, спроси otvet5GPT

  • Быстро
    Мгновенный ответ на твой вопрос
  • Точно
    Бот обладает знаниями во всех сферах
  • Бесплатно
    Задай вопрос и получи ответ бесплатно

Популярно: Информатика

Caktus Image

Есть вопросы?

  • Как otvet5GPT работает?

    otvet5GPT использует большую языковую модель вместе с базой данных GPT для обеспечения высококачественных образовательных результатов. otvet5GPT действует как доступный академический ресурс вне класса.
  • Сколько это стоит?

    Проект находиться на стадии тестирования и все услуги бесплатны.
  • Могу ли я использовать otvet5GPT в школе?

    Конечно! Нейросеть может помочь вам делать конспекты лекций, придумывать идеи в классе и многое другое!
  • В чем отличия от ChatGPT?

    otvet5GPT черпает академические источники из собственной базы данных и предназначен специально для студентов. otvet5GPT также адаптируется к вашему стилю письма, предоставляя ряд образовательных инструментов, предназначенных для улучшения обучения.

Подпишись на наш телеграмм канал

GTP TOP NEWS