Есть ответ 👍

Составьте программу для решения следующей . введите с клавиатуры два числа: n и m. если оба числа больше 100, то замените каждое из них меньшим и выведите результаты на экран. если первое число положительное, а второе отрицательное, то уменьшите их в два раза и выведите результаты. иначе, найдите и выведите среднее арифметическое этих чисел.

267
425
Посмотреть ответы 2

Ответы на вопрос:

Lika39211
4,4(71 оценок)

Program a1; var n,m,k: real; begin writeln('введите числа n и m'); readln(n,m); if n> 100 and m> 100 then n: =n-1; m: =m-1; writeln(m,n); if n> 0 and m< 0 then n: =n/2; m: =m/2; writeln(n,m) else k: =0; k: =(m+n)/2; writeln(k); end.

16=2^4 - значит один символ несет 4 бит информации. 50 символов * 4 бита = 200 бит информации несет сообщение.

Реши свою проблему, спроси otvet5GPT

  • Быстро
    Мгновенный ответ на твой вопрос
  • Точно
    Бот обладает знаниями во всех сферах
  • Бесплатно
    Задай вопрос и получи ответ бесплатно

Популярно: Информатика

Caktus Image

Есть вопросы?

  • Как otvet5GPT работает?

    otvet5GPT использует большую языковую модель вместе с базой данных GPT для обеспечения высококачественных образовательных результатов. otvet5GPT действует как доступный академический ресурс вне класса.
  • Сколько это стоит?

    Проект находиться на стадии тестирования и все услуги бесплатны.
  • Могу ли я использовать otvet5GPT в школе?

    Конечно! Нейросеть может помочь вам делать конспекты лекций, придумывать идеи в классе и многое другое!
  • В чем отличия от ChatGPT?

    otvet5GPT черпает академические источники из собственной базы данных и предназначен специально для студентов. otvet5GPT также адаптируется к вашему стилю письма, предоставляя ряд образовательных инструментов, предназначенных для улучшения обучения.

Подпишись на наш телеграмм канал

GTP TOP NEWS