Есть ответ 👍

Написать программу на паскале, используя вместо for - while. ! 1. напишите программу, которая в последовательности из 12 натуральных чисел определяет минимальное чётное число. программа получает на вход натуральные числа. в последовательности всегда имеется чётное число. введённые числа не превышают 30 000. программа должна вывести одно число – минимальное чётное число. 2. напишите программу, которая в последовательности из 12 натуральных чисел определяет максимальное число, оканчивающееся на 2. программа получает на вход натуральные числа. введённые числа не превышают30 000. программа должна вывести одно число – максимальное число, оканчивающееся на 2.

128
134
Посмотреть ответы 2

Ответы на вопрос:

dvortrans
4,5(80 оценок)

1)    var     a ,i,min: integer; begin min : = 30000;   i : = 0;   while i < > 12 do   begin     readln(a);     if (a< min) and (a mod 2 = 0) then     min : = a;     i : = i +1;   end; writeln (min); end. 2)   var    a ,i,max: integer; begin max : = 0;     i : = 0;   while i < > 12 do  begin    readln(a);     if (a> max) and (a mod 10 = 2) then    max : = a;     i : = i +1;   end; writeln (max); end.

1)

                                                    начало

                                                  делим на 2

                          есть остаток                               нет остатка

                          возводим в куб                         возводим в кводрат

                                                    конец        

2)х*7=> *500=> *3=> *28=> *25.4=> /10=> /10=> /10=> /1000

/10)/10)/10)/1000=1/(10^6)=мм/км(для особо одаренных^^)

Реши свою проблему, спроси otvet5GPT

  • Быстро
    Мгновенный ответ на твой вопрос
  • Точно
    Бот обладает знаниями во всех сферах
  • Бесплатно
    Задай вопрос и получи ответ бесплатно

Популярно: Информатика

Caktus Image

Есть вопросы?

  • Как otvet5GPT работает?

    otvet5GPT использует большую языковую модель вместе с базой данных GPT для обеспечения высококачественных образовательных результатов. otvet5GPT действует как доступный академический ресурс вне класса.
  • Сколько это стоит?

    Проект находиться на стадии тестирования и все услуги бесплатны.
  • Могу ли я использовать otvet5GPT в школе?

    Конечно! Нейросеть может помочь вам делать конспекты лекций, придумывать идеи в классе и многое другое!
  • В чем отличия от ChatGPT?

    otvet5GPT черпает академические источники из собственной базы данных и предназначен специально для студентов. otvet5GPT также адаптируется к вашему стилю письма, предоставляя ряд образовательных инструментов, предназначенных для улучшения обучения.

Подпишись на наш телеграмм канал

GTP TOP NEWS