Есть ответ 👍

Составить программу,которая в зависимости от порядкового номера месяца выводит на экран количество дней в этом месяце.рассмотреть два случая: 1.год високосный. 2.год не является високосным

168
176
Посмотреть ответы 2

Ответы на вопрос:


Program g; uses crt; var count, num, ch: integer; begin    clrscr;     writeln('год високосный? 1 - да, 0 - нет');     readln(ch);     if ch=1 then      begin        writeln('введите номер месяца');       readln(num);         сase num of          1, 3, 5, 7, 8, 10, 12: writeln('в месяце 31 день.');         4, 6, 9, 11: writeln('в месяце 30 дней.');         2: writeln('в месяце 29 дней');         else writeln('некорректный ввод данных')      end;     end      else if ch=0   then      begin        writeln('введите номер месяца');         readln(num);     сase num of            1, 3, 5, 7, 8, 10, 12: writeln('в месяце 31 день.');           4, 6, 9, 11: writeln('в месяце 30 дней.');           2: writeln('в месяце 28 дней');         else writeln('некорректный ввод данных')        end;       end    else writeln('некорректный ввод данных'); readln;   end.

0, 4, 4 ;

4 во втором 1, 2, 3,4

4 и в третьем при 2, 1, 0, -1

Реши свою проблему, спроси otvet5GPT

  • Быстро
    Мгновенный ответ на твой вопрос
  • Точно
    Бот обладает знаниями во всех сферах
  • Бесплатно
    Задай вопрос и получи ответ бесплатно

Популярно: Информатика

Caktus Image

Есть вопросы?

  • Как otvet5GPT работает?

    otvet5GPT использует большую языковую модель вместе с базой данных GPT для обеспечения высококачественных образовательных результатов. otvet5GPT действует как доступный академический ресурс вне класса.
  • Сколько это стоит?

    Проект находиться на стадии тестирования и все услуги бесплатны.
  • Могу ли я использовать otvet5GPT в школе?

    Конечно! Нейросеть может помочь вам делать конспекты лекций, придумывать идеи в классе и многое другое!
  • В чем отличия от ChatGPT?

    otvet5GPT черпает академические источники из собственной базы данных и предназначен специально для студентов. otvet5GPT также адаптируется к вашему стилю письма, предоставляя ряд образовательных инструментов, предназначенных для улучшения обучения.

Подпишись на наш телеграмм канал

GTP TOP NEWS