Есть ответ 👍

N-factorial это произведение всех чисел от 1 до n. для задного числа n определите сколько нулей в конце десятичной записи n-factorial . в единственной строке входного файла содержится одно целое положительное числа nn(1

121
304
Посмотреть ответы 2

Ответы на вопрос:

vikonil
4,4(73 оценок)

Сначала банальный код - рабочий, но уже  на больших числах будет переполнение переменной факториала. var n, i, fact, ans : integer; begin   read(n);   fact : = 1;   for i : = 2 to n do     fact : = fact * i;   while (fact mod 10 = 0) do begin     ans : = ans + 1;       fact : = fact div 10;   end;   writeln(ans); end.теперь более "умный" код, в нём использован тот факт, что простое число p входит в разложение факториала  числа n = [n/p] + [n/p^2] + [n/p^3] + где [x] - целая часть числа x.var n, i, fact, c, pow, ans : integer; {c  - сколько раз входит в разложение числа n! цифра  5}begin  read(n);   pow : = 5;   while (pow < = n) do begin    c += n div pow;     pow : = pow * 5;   end;   writeln(c); end.

Юля - Невиномысск

Таня - Мурманск

Аня - Тверь

Катя - Подольск

Вика - Самара

Объяснение:

Реши свою проблему, спроси otvet5GPT

  • Быстро
    Мгновенный ответ на твой вопрос
  • Точно
    Бот обладает знаниями во всех сферах
  • Бесплатно
    Задай вопрос и получи ответ бесплатно

Популярно: Информатика

Caktus Image

Есть вопросы?

  • Как otvet5GPT работает?

    otvet5GPT использует большую языковую модель вместе с базой данных GPT для обеспечения высококачественных образовательных результатов. otvet5GPT действует как доступный академический ресурс вне класса.
  • Сколько это стоит?

    Проект находиться на стадии тестирования и все услуги бесплатны.
  • Могу ли я использовать otvet5GPT в школе?

    Конечно! Нейросеть может помочь вам делать конспекты лекций, придумывать идеи в классе и многое другое!
  • В чем отличия от ChatGPT?

    otvet5GPT черпает академические источники из собственной базы данных и предназначен специально для студентов. otvet5GPT также адаптируется к вашему стилю письма, предоставляя ряд образовательных инструментов, предназначенных для улучшения обучения.

Подпишись на наш телеграмм канал

GTP TOP NEWS