Есть ответ 👍

Составьте программу, которая заполняет массив a[1..10] случайными целыми числами в диапазоне от 1 до 10 и вычисляет сумму элементов массива с индексами от n до m включительно. числа n и m введите с клавиатуры.

231
455
Посмотреть ответы 2

Ответы на вопрос:

dkurmanbek
4,6(17 оценок)

Var    a: array [1..10] of integer;   s,i,m,n: integer; begin   randomize;   for i : = 1 to 10 do begin     a[i] : = random(10)+1;     write(a[i], ' ');   end;   write(#13+#10+'n = '); readln(n);   write('m = '); readln(m);   if n < 1 then n : = 1;   if m > 10 then m : = 10;   s : = 0;   for i : = n to m do s : = s + a[i];   writeln('s[',n,'..',m,']=',s ); end.
ruzruz258
4,7(86 оценок)

S: =0; //  сумма for i: =1 to n do //  n - количество элементов в массиве   if a[i]> 0 then    s: =s+a[i];

Реши свою проблему, спроси otvet5GPT

  • Быстро
    Мгновенный ответ на твой вопрос
  • Точно
    Бот обладает знаниями во всех сферах
  • Бесплатно
    Задай вопрос и получи ответ бесплатно

Популярно: Информатика

Caktus Image

Есть вопросы?

  • Как otvet5GPT работает?

    otvet5GPT использует большую языковую модель вместе с базой данных GPT для обеспечения высококачественных образовательных результатов. otvet5GPT действует как доступный академический ресурс вне класса.
  • Сколько это стоит?

    Проект находиться на стадии тестирования и все услуги бесплатны.
  • Могу ли я использовать otvet5GPT в школе?

    Конечно! Нейросеть может помочь вам делать конспекты лекций, придумывать идеи в классе и многое другое!
  • В чем отличия от ChatGPT?

    otvet5GPT черпает академические источники из собственной базы данных и предназначен специально для студентов. otvet5GPT также адаптируется к вашему стилю письма, предоставляя ряд образовательных инструментов, предназначенных для улучшения обучения.

Подпишись на наш телеграмм канал

GTP TOP NEWS