Есть ответ 👍

Напишите программу, которая в последовательности натуральных чисел определяет сумму чисел, оканчивающихся на 3. программа получает на вход количество чисел в последовательности, а затем сами числа. в последовательности всегда имеется число, оканчивающиеся на 3. кол-во чисел не превышает 100. введённые числа не превышают 300. программа должна вывести одно число - сумму чисел, оканчивающихся на 3.

258
314
Посмотреть ответы 2

Ответы на вопрос:

Mамикс
4,4(83 оценок)

Program a; var a,b,c,s: integer; begin write('введите кол-во чисел в последовательности: '); readln(a); for c: =1 to a do begin write('введите число: '); readln(b); if (b mod 10=3) then s: =s+b; write(b,' '); end; writeln('сумма  чисел, оканчивающихся на 3=',s); end. с клавиатуры вводится кол-во чисел в последовательности и каждое число послед-ти  на экран  выводится последовательность чисел через пробел и сумму  чисел, оканчивающихся на 3 program b; var a,b,s: integer; begin write('введите кол-во чисел в последовательности: '); readln(a); for c: =1 to a do b: =random(300)+1; if (b mod 10=3) then s: =s+b; write(b,' '); end; writeln('сумма  чисел, оканчивающихся на 3=',s); end. с клавиатуры вводится   только  кол-во чисел в последовательности а каждое число послед-ти вводится само рандомно.  на экран  выводится последовательность чисел через пробел и сумму  чисел, оканчивающихся на 3  

1-в

2-а

3-г

4-г

6-а

7-Г

8-15*8=120бит

Реши свою проблему, спроси otvet5GPT

  • Быстро
    Мгновенный ответ на твой вопрос
  • Точно
    Бот обладает знаниями во всех сферах
  • Бесплатно
    Задай вопрос и получи ответ бесплатно

Популярно: Информатика

Caktus Image

Есть вопросы?

  • Как otvet5GPT работает?

    otvet5GPT использует большую языковую модель вместе с базой данных GPT для обеспечения высококачественных образовательных результатов. otvet5GPT действует как доступный академический ресурс вне класса.
  • Сколько это стоит?

    Проект находиться на стадии тестирования и все услуги бесплатны.
  • Могу ли я использовать otvet5GPT в школе?

    Конечно! Нейросеть может помочь вам делать конспекты лекций, придумывать идеи в классе и многое другое!
  • В чем отличия от ChatGPT?

    otvet5GPT черпает академические источники из собственной базы данных и предназначен специально для студентов. otvet5GPT также адаптируется к вашему стилю письма, предоставляя ряд образовательных инструментов, предназначенных для улучшения обучения.

Подпишись на наш телеграмм канал

GTP TOP NEWS