Есть ответ 👍

Составьте быстро! 1)составьте программу вычесления суммы s=1+2^2+3^3+4^4++n^n. 2)даны годовые оценки учеников класса по .верно ли ,что количесвто пятерок больше,чем двоек? 3)известна высота двадцати зданий.найти минимальную высоту. 4известна высота двадцати зданий.найти два максимальный значения

288
344
Посмотреть ответы 2

Ответы на вопрос:


Var p, q: longint;   n, i, j, c: integer; begin    // 1   write('n='); readln(n);   for i : = 1 to n do begin     q : = 1;     for j : = 1 to i do q : = q * i;     p : = p + q;   end;   writeln ('значение = ', p);       // 2   write('число годовых оценок='); readln(n);   p: =0;   for i : = 1 to n do begin     write('оценка: '); readln(c);     if c = 5 then p : = p + 1     else if c = 2 then p : = - 1;   end;   writeln(p > 0);       // 3   n : = 20; p : = maxint;   for i : = 1 to n do begin     write('введите высоту здания ', i, ': ');     readln(c);     if c < p then p : = c;   end;   writeln('минимальная высота: ', p);       //4   n : = 20; p : = -1;   for i : = 1 to n do begin     write('введите высоту здания ', i, ': ');     readln(c);     if c > p then p : = c;   end;   writeln('максимальное значение высоты: ', p); end.
kodwaw
4,8(35 оценок)

Var       i, n, prev_n: integer; begin       i : = 0;       writeln('введите последовательность чисел,оканчивающихся 0');             repeat               readln(n);               if prev_n * n < 0 then                       i : = i + 1;               prev_n : = n;       until n = 0;             writeln(i); end.

Реши свою проблему, спроси otvet5GPT

  • Быстро
    Мгновенный ответ на твой вопрос
  • Точно
    Бот обладает знаниями во всех сферах
  • Бесплатно
    Задай вопрос и получи ответ бесплатно

Популярно: Информатика

Caktus Image

Есть вопросы?

  • Как otvet5GPT работает?

    otvet5GPT использует большую языковую модель вместе с базой данных GPT для обеспечения высококачественных образовательных результатов. otvet5GPT действует как доступный академический ресурс вне класса.
  • Сколько это стоит?

    Проект находиться на стадии тестирования и все услуги бесплатны.
  • Могу ли я использовать otvet5GPT в школе?

    Конечно! Нейросеть может помочь вам делать конспекты лекций, придумывать идеи в классе и многое другое!
  • В чем отличия от ChatGPT?

    otvet5GPT черпает академические источники из собственной базы данных и предназначен специально для студентов. otvet5GPT также адаптируется к вашему стилю письма, предоставляя ряд образовательных инструментов, предназначенных для улучшения обучения.

Подпишись на наш телеграмм канал

GTP TOP NEWS