Есть ответ 👍

Написать программу в паскале! надо! задана последовательность целых чисел,количество которых не превосходит 100.требуется определить за один проход элемент с максимальным значением,а также число его повторений в последовательности.

229
364
Посмотреть ответы 3

Ответы на вопрос:

578fyvhjj
4,7(87 оценок)

Program maxof; var ar: array [1..100] of integer; i, j, posl: shortint; max: integer; begin readln(i); for j: =1 to i do begin readln(ar[j]); end; max: =ar[1]; posl: =1; for j: =2 to i do begin if max = ar[j] then inc(posl); if max < ar[j] then begin posl: =1; max: =ar[j] end;   end; writeln(max, ' x', posl); end.

Var   i,k,max: integer;   a: array[1..100]of integer; begin writeln('исходная последовательность: '); for i: =1 to 100 do   begin   a[i]: =random(200);   write(a[i],' ');   if a[i]> max then     begin     max: =a[i];     k: =1;     end;   if a[i]=max then     k: =k+1;   end; writeln; writeln('максимальное значение: ',max); writeln('число повторений: ',k) end.
Roblox777
4,5(38 оценок)

Переведём минуты в секунды: 2 минуты, 8 секунд = 128 секунд узнаем вес текста, который скачал петя: 16  × 128 = 2048 килобайт один символ в кодировке ascii весит 1 байт 2048 килобайт = 2048  × 1024 =  2097152 байт значит петя передал 2097152 символа в сообщении.

Реши свою проблему, спроси otvet5GPT

  • Быстро
    Мгновенный ответ на твой вопрос
  • Точно
    Бот обладает знаниями во всех сферах
  • Бесплатно
    Задай вопрос и получи ответ бесплатно

Популярно: Информатика

Caktus Image

Есть вопросы?

  • Как otvet5GPT работает?

    otvet5GPT использует большую языковую модель вместе с базой данных GPT для обеспечения высококачественных образовательных результатов. otvet5GPT действует как доступный академический ресурс вне класса.
  • Сколько это стоит?

    Проект находиться на стадии тестирования и все услуги бесплатны.
  • Могу ли я использовать otvet5GPT в школе?

    Конечно! Нейросеть может помочь вам делать конспекты лекций, придумывать идеи в классе и многое другое!
  • В чем отличия от ChatGPT?

    otvet5GPT черпает академические источники из собственной базы данных и предназначен специально для студентов. otvet5GPT также адаптируется к вашему стилю письма, предоставляя ряд образовательных инструментов, предназначенных для улучшения обучения.

Подпишись на наш телеграмм канал

GTP TOP NEWS