Есть ответ 👍

Нужно написать программу на с++. идет n-я секунда суток. определить, сколько полных часов и полных минут прошло до этого момента. + отформатировать исходный код программы. + определить ограничения на задаваемые пользователем значения и не допустить ввода неверных щначений

122
442
Посмотреть ответы 2

Ответы на вопрос:

kartew
4,6(56 оценок)

#include< iostream.h>

  using namespace std;

int main() 

{

      int n=0;

      cout< < "введите секунды."< < endl;

      cin> > n;

      if(n> 60*60*24)

      {

        cout< < "неправельный ввод: в сутках меньше, чем "< < n< < " секунд"< < endl;

      }

      else

      {

        cout< < "прошло полных часов: "< < (n-n%3600)/3600< < endl;

        cout< < "прошло полных минут: "< < (n-n%60)/60< < endl;

      }

      system("pause");       return 0;       }

 

/*

  в некоторых компиляторах нельзя выводить текст таким образом, нужно выводить текст или второй вариант программы:

 

#include< iostream.h>

#include< windows.h>

  using namespace std;

 

char bufrus[256];   char* rus(const char* text)

{          chartooem(text, bufrus);           return bufrus; }

int main() 

{

      int n=0;

      cout< < rus("введите секунды.")< < endl;

      cin> > n;

      if(n> 60*60*24)

      {

        cout< < rus("неправельный ввод: в сутках меньше, чем ")< < n< < rus(" секунд")< < endl;

      }

      else

      {

        cout< < rus("прошло полных часов: ")< < (n-n%3600)/3600< < endl;

        cout< < rus("прошло полных минут: ")< < (n-n%60)/60< < endl;

      }

      system("pause");       return 0;       }

 

  p.s сорри, что не , увидел только сейчас.

*/

Husky333
4,8(32 оценок)

program n_1;

var i, s: integer;

begin

    s: =0;

    for i: =1 to 10 do if i mod 2 = 0 then s: =s+i;

    writeln(s);

end.

Реши свою проблему, спроси otvet5GPT

  • Быстро
    Мгновенный ответ на твой вопрос
  • Точно
    Бот обладает знаниями во всех сферах
  • Бесплатно
    Задай вопрос и получи ответ бесплатно

Популярно: Информатика

Caktus Image

Есть вопросы?

  • Как otvet5GPT работает?

    otvet5GPT использует большую языковую модель вместе с базой данных GPT для обеспечения высококачественных образовательных результатов. otvet5GPT действует как доступный академический ресурс вне класса.
  • Сколько это стоит?

    Проект находиться на стадии тестирования и все услуги бесплатны.
  • Могу ли я использовать otvet5GPT в школе?

    Конечно! Нейросеть может помочь вам делать конспекты лекций, придумывать идеи в классе и многое другое!
  • В чем отличия от ChatGPT?

    otvet5GPT черпает академические источники из собственной базы данных и предназначен специально для студентов. otvet5GPT также адаптируется к вашему стилю письма, предоставляя ряд образовательных инструментов, предназначенных для улучшения обучения.

Подпишись на наш телеграмм канал

GTP TOP NEWS