Есть ответ 👍

Сделать на pascalabc, попросили сделать с записей. составить программу, которая вводит данные о студентах: № п/п, фамилию, год рождения, пол, курс, вид спорта и выводит: выводит данные только о спортсменках по курсам и спорта в алфавитном порядке.

114
320
Посмотреть ответы 2

Ответы на вопрос:


Const n=3; type student=recordfam: string[20]; year: integer; sex: string[1]; kurs: integer; sport: string[30]; end; var x: array[1..n] of student; i,j: integer; p: student; beginfor i: =1 to n dowith x[i] do beginwriteln('сведенья о ',i,' студенте: '); writeln('фамилия: '); read(fam); writeln('год рождения: '); read(year); writeln('пол( м или ж ): '); read(sex); writeln('курс: '); read(kurs); writeln('вид спорта: '); read(sport); end; for i: =1 to n-1 dofor j: =i+1 to n doif x[i].fam> x[j].fam then beginp: =x[i]; x[i]: =x[j]; x[j]: =p; end; for i: =1 to n do beginwith x[i] doif (sex='ж') then writeln('фамилия студентки:   ',fam,' курс:   ',kurs,' вид спорта:     ',sport); end; end.

// Работает под Pascal ABC.NET
// Заводим переменные

var

// Нужно n типа целое для того, чтобы хранить ввод пользователя

 n: Integer;

// По условию задачи необходим массив. Тк N <= 20, то заводим от 1 до 20.

// В массиве будут храниться целые поэтому Integer

 a: Array [1 .. 20] of Integer;

// Также нам понадобится счетчик, указывающий на обрабатываемый элемент массива

 i: Integer;

begin

 // Считываем n с клавиатуры

 ReadLn(n);

 // Пусть первый элемент равен 1

 a[1] := 1;

 // Каждый последующий элемент массива

 for i := 2 to n do

   // Равен предыдущему элементу массива умноженному на 2

   a[i] := a[i-1] * 2;

 // Вывод каждого элемента массива через пробел

 for i := 1 to n do

   Write(a[i], ' ');

end.

 

Реши свою проблему, спроси otvet5GPT

  • Быстро
    Мгновенный ответ на твой вопрос
  • Точно
    Бот обладает знаниями во всех сферах
  • Бесплатно
    Задай вопрос и получи ответ бесплатно

Популярно: Информатика

Caktus Image

Есть вопросы?

  • Как otvet5GPT работает?

    otvet5GPT использует большую языковую модель вместе с базой данных GPT для обеспечения высококачественных образовательных результатов. otvet5GPT действует как доступный академический ресурс вне класса.
  • Сколько это стоит?

    Проект находиться на стадии тестирования и все услуги бесплатны.
  • Могу ли я использовать otvet5GPT в школе?

    Конечно! Нейросеть может помочь вам делать конспекты лекций, придумывать идеи в классе и многое другое!
  • В чем отличия от ChatGPT?

    otvet5GPT черпает академические источники из собственной базы данных и предназначен специально для студентов. otvet5GPT также адаптируется к вашему стилю письма, предоставляя ряд образовательных инструментов, предназначенных для улучшения обучения.

Подпишись на наш телеграмм канал

GTP TOP NEWS