Есть ответ 👍

Напишите программу для 2. на плоскости дан треугольник abc, задаваемый координатами своих вершин (вводятся три пары чисел). определить, является ли треугольник abc прямоугольным. дополнительно: определить координаты центра треугольника.

223
480
Посмотреть ответы 2

Ответы на вопрос:

fsks
4,6(3 оценок)

Var   a: array [1..6] of real;   q, b, c: real; begin   for i: byte : = 0 to 2 do     readln(a[i * 2 + 1], a[i * 2 + 2]);   q : = sqrt(sqr(a[1] - a[3]) + sqr(a[2] - a[4]));   b : = sqrt(sqr(a[5] - a[3]) + sqr(a[6] - a[4]));   c : = sqrt(sqr(a[5] - a[1]) + sqr(a[6] - a[2]));   if ((q + b > c) and (q + c > b) and (b + c > q)) then   begin     if (max(q, max(b, c)) = sqrt(sqr(min(q, min(b, + sqr(min(q, max(b, then        writeln('прямоугольный! ');     writeln(string.format('геом. центр - ({0}; {1})', (a[1] + a[3] + a[5]) / 3, (a[2] + a[4] + a[6]) / 3));   end   else     writeln('нет такого ▲'); end.

Скорее всего microsoft office - офисный пакет приложений. к нему входят: word, exell, power point, access и т.д. это и учат в школе. 

Реши свою проблему, спроси otvet5GPT

  • Быстро
    Мгновенный ответ на твой вопрос
  • Точно
    Бот обладает знаниями во всех сферах
  • Бесплатно
    Задай вопрос и получи ответ бесплатно

Популярно: Информатика

Caktus Image

Есть вопросы?

  • Как otvet5GPT работает?

    otvet5GPT использует большую языковую модель вместе с базой данных GPT для обеспечения высококачественных образовательных результатов. otvet5GPT действует как доступный академический ресурс вне класса.
  • Сколько это стоит?

    Проект находиться на стадии тестирования и все услуги бесплатны.
  • Могу ли я использовать otvet5GPT в школе?

    Конечно! Нейросеть может помочь вам делать конспекты лекций, придумывать идеи в классе и многое другое!
  • В чем отличия от ChatGPT?

    otvet5GPT черпает академические источники из собственной базы данных и предназначен специально для студентов. otvet5GPT также адаптируется к вашему стилю письма, предоставляя ряд образовательных инструментов, предназначенных для улучшения обучения.

Подпишись на наш телеграмм канал

GTP TOP NEWS