Есть ответ 👍

Написать программу в pascal, используя массивы. дано массив а[1..n]. сделать программу которая выводит те элементы массива? индексы которых являются степени двойки желательно с обьяснением строк

175
399
Посмотреть ответы 2

Ответы на вопрос:

Gatkek
4,6(2 оценок)

Const   n = 100; var   a: array[1..n] of integer;   i: integer; begin   //заполняем массив случайными значениями в диапазоне [0; 100]   randomize; //инициализация датчика случайных чисел   for i : = 1 to n do a[i] : = random(100);   i : = 1;   //1 - это два в нулевой степени   while i < n do   begin       writeln('a(', i, ')=', a[i]);       i : = 2 * i;   //удваиваем индекс, чтобы получить очередную степень двойки   end end. результат работы программы: a(1)=26 a(2)=21 a(4)=29 a(8)=74 a(16)=23 a(32)=44 a(64)=20
ekzz1
4,6(28 оценок)

Вам необходимо создать программу-калькулятор

...

Реши свою проблему, спроси otvet5GPT

  • Быстро
    Мгновенный ответ на твой вопрос
  • Точно
    Бот обладает знаниями во всех сферах
  • Бесплатно
    Задай вопрос и получи ответ бесплатно

Популярно: Информатика

Caktus Image

Есть вопросы?

  • Как otvet5GPT работает?

    otvet5GPT использует большую языковую модель вместе с базой данных GPT для обеспечения высококачественных образовательных результатов. otvet5GPT действует как доступный академический ресурс вне класса.
  • Сколько это стоит?

    Проект находиться на стадии тестирования и все услуги бесплатны.
  • Могу ли я использовать otvet5GPT в школе?

    Конечно! Нейросеть может помочь вам делать конспекты лекций, придумывать идеи в классе и многое другое!
  • В чем отличия от ChatGPT?

    otvet5GPT черпает академические источники из собственной базы данных и предназначен специально для студентов. otvet5GPT также адаптируется к вашему стилю письма, предоставляя ряд образовательных инструментов, предназначенных для улучшения обучения.

Подпишись на наш телеграмм канал

GTP TOP NEWS