Есть ответ 👍

Написать программу, которая запрашивает массив из n элементов и увеличивает все элементы массива на максимальный элемент. протестировать программу на массивах размерностью 8 и 10 элементов.

264
305
Посмотреть ответы 2

Ответы на вопрос:


Program z1;         var a: array[1..100] of integer;         n,i: byte; ma: integer; begin         write('n='); readln(n);         for i: =1 to n do begin                 write(i,')'); readln(a[i])         end;         ma: =a[1];         for i: =1 to n do begin                 if a[i]> ma then begin                         ma: =a[i]                 end         end;         for i: =1 to n do begin                 a[i]: =ma         end;         writeln('test n=',n);         for i: =1 to n do begin                 writeln(a[i])         end;         readln end.
Veid
4,8(63 оценок)

n=(1,2,3,4,6)

sum=0

for el in n:

   sum=sum+el

print(sum/(len(n)))

Реши свою проблему, спроси otvet5GPT

  • Быстро
    Мгновенный ответ на твой вопрос
  • Точно
    Бот обладает знаниями во всех сферах
  • Бесплатно
    Задай вопрос и получи ответ бесплатно

Популярно: Информатика

Caktus Image

Есть вопросы?

  • Как otvet5GPT работает?

    otvet5GPT использует большую языковую модель вместе с базой данных GPT для обеспечения высококачественных образовательных результатов. otvet5GPT действует как доступный академический ресурс вне класса.
  • Сколько это стоит?

    Проект находиться на стадии тестирования и все услуги бесплатны.
  • Могу ли я использовать otvet5GPT в школе?

    Конечно! Нейросеть может помочь вам делать конспекты лекций, придумывать идеи в классе и многое другое!
  • В чем отличия от ChatGPT?

    otvet5GPT черпает академические источники из собственной базы данных и предназначен специально для студентов. otvet5GPT также адаптируется к вашему стилю письма, предоставляя ряд образовательных инструментов, предназначенных для улучшения обучения.

Подпишись на наш телеграмм канал

GTP TOP NEWS