Есть ответ 👍

Составить программу , в среде pascal abc (turbo pascal) выполняющую вычисления по формуле: y=2ctg3x-

298
353
Посмотреть ответы 2

Ответы на вопрос:


Паскаль авс: program ikiru; uses crt; var   y,x: real; begin   writeln('*** alphaeus is ***');   writeln('***                  ok                        ***');   writeln(); writeln();       write('введите х '); readln(x);       if (sin(3*x)=0) or (ln(1+x*x)=0) or (cos(x)< =0)           then               writeln('функция y для этого значения х не определена')           else               begin                   y: =2*(cos(3*x)/sin(3*(cos(x))/ln(1+x*x);                   writeln('y=',y: 8: 2);               end; end. пояснения: write('введите х '); readln(x);   - программа просит пользователя ввести х if (sin(3*x)=0) or (ln(1+x*x)=0) or (cos(x)< =0)   - проверка существования функции (функция ctgх не существует, если sinx=0, ln берется только от неотрицательных значений, в знаменателе дроби не может быть 0) если хотя бы одно из условий не выполняется,  выводится ссобщение о том, что функция для этого значения не определена. если все проверки пройдены, программа вычисляет значение функции y и выводит его на экран.

А

Реши свою проблему, спроси otvet5GPT

  • Быстро
    Мгновенный ответ на твой вопрос
  • Точно
    Бот обладает знаниями во всех сферах
  • Бесплатно
    Задай вопрос и получи ответ бесплатно

Популярно: Информатика

Caktus Image

Есть вопросы?

  • Как otvet5GPT работает?

    otvet5GPT использует большую языковую модель вместе с базой данных GPT для обеспечения высококачественных образовательных результатов. otvet5GPT действует как доступный академический ресурс вне класса.
  • Сколько это стоит?

    Проект находиться на стадии тестирования и все услуги бесплатны.
  • Могу ли я использовать otvet5GPT в школе?

    Конечно! Нейросеть может помочь вам делать конспекты лекций, придумывать идеи в классе и многое другое!
  • В чем отличия от ChatGPT?

    otvet5GPT черпает академические источники из собственной базы данных и предназначен специально для студентов. otvet5GPT также адаптируется к вашему стилю письма, предоставляя ряд образовательных инструментов, предназначенных для улучшения обучения.

Подпишись на наш телеграмм канал

GTP TOP NEWS