Есть ответ 👍

Требовалось написать программу,при выполнении которой с клавиатуры вводится натуральное число,не превосходящее 10^8, и выводится его первая цифра.ученик написал такую программу: var n: longint; begin read(n); while n> 10 do begin n: =n mod 10 end; write(n); end. 1)напишите,что выведет эта программа при вводе числа 1984. 2) пример числа,при вводе которого программа выдаст верный ответ. 3)найдите в программе все ошибки.

267
386
Посмотреть ответы 2

Ответы на вопрос:

davidgts
4,5(86 оценок)

1) 4 2) 7 3) мы в цикле берем остаток от деления на 10 => последнюю цифру, нужно поменять на n: =n div 10

Список -  это перечень значений, из которых следует выбрать одно нужное

Реши свою проблему, спроси otvet5GPT

  • Быстро
    Мгновенный ответ на твой вопрос
  • Точно
    Бот обладает знаниями во всех сферах
  • Бесплатно
    Задай вопрос и получи ответ бесплатно

Популярно: Информатика

Caktus Image

Есть вопросы?

  • Как otvet5GPT работает?

    otvet5GPT использует большую языковую модель вместе с базой данных GPT для обеспечения высококачественных образовательных результатов. otvet5GPT действует как доступный академический ресурс вне класса.
  • Сколько это стоит?

    Проект находиться на стадии тестирования и все услуги бесплатны.
  • Могу ли я использовать otvet5GPT в школе?

    Конечно! Нейросеть может помочь вам делать конспекты лекций, придумывать идеи в классе и многое другое!
  • В чем отличия от ChatGPT?

    otvet5GPT черпает академические источники из собственной базы данных и предназначен специально для студентов. otvet5GPT также адаптируется к вашему стилю письма, предоставляя ряд образовательных инструментов, предназначенных для улучшения обучения.

Подпишись на наш телеграмм канал

GTP TOP NEWS