Есть ответ 👍

Напишите программу, которая в последовательности целых чисел находит сумму и количество чисел, кратных 17, или сообщает, что таких чисел нет. на вход программы целые числа, количество введенных чисел неизвестно, последовательность заканчивается числом 0 (0 - признак окончания ввода, не является членом последовательности). количество чисел не превышает 100. введенные числа по модулю не превышают 300. программа должна вывести сумму и количество чисел, кратных 17, или вывести no, если таких числе в последовательности нет

129
374
Посмотреть ответы 2

Ответы на вопрос:

додо7
4,4(51 оценок)

Var summa,count,numb : integer; begin summa: =0; count: =0; readln(numb); while numb < > 0 do begin if numb mod 17 = 0 then begin summa: =summa+numb; count: =count+1; end; readln(numb); end; if (summa > 0) and (count > 0) then writeln(summa,'   ',count) else  writeln('no'); end.

источник : тот кто гладит кота , потому что он отдает свою любовь коту

а применик кот ,потому что он принимает поглаживания человека .

Реши свою проблему, спроси otvet5GPT

  • Быстро
    Мгновенный ответ на твой вопрос
  • Точно
    Бот обладает знаниями во всех сферах
  • Бесплатно
    Задай вопрос и получи ответ бесплатно

Популярно: Информатика

Caktus Image

Есть вопросы?

  • Как otvet5GPT работает?

    otvet5GPT использует большую языковую модель вместе с базой данных GPT для обеспечения высококачественных образовательных результатов. otvet5GPT действует как доступный академический ресурс вне класса.
  • Сколько это стоит?

    Проект находиться на стадии тестирования и все услуги бесплатны.
  • Могу ли я использовать otvet5GPT в школе?

    Конечно! Нейросеть может помочь вам делать конспекты лекций, придумывать идеи в классе и многое другое!
  • В чем отличия от ChatGPT?

    otvet5GPT черпает академические источники из собственной базы данных и предназначен специально для студентов. otvet5GPT также адаптируется к вашему стилю письма, предоставляя ряд образовательных инструментов, предназначенных для улучшения обучения.

Подпишись на наш телеграмм канал

GTP TOP NEWS