Есть ответ 👍

Напишите программу, которая вычисляет сумму: а) первых n натуральных чисел б) квадраов первых n натуральных чисел в) всех четных чисел в диапозоне от 1 до n г) всех двухзначных чисел

300
500
Посмотреть ответы 2

Ответы на вопрос:

valera253
4,6(36 оценок)

Program d1lpxx10; uses crt; var i,n,sum4,sumkv,sum4et,sumdvy: integer; begin read(n); for i: =1 to n do sum4: =sum4+i; for i: =1 to n do sumkv: =sumkv+i*i; for i: =1 to n do if i mod 2=0 then sum4et: =sum4et+i; for i: =10 to 99 do sumdvy: =sumdvy+i; writeln('summa=',sum4,' summa kvadratov=',sumkv,' summa 4etnblx=',sum4et,' summa dvyzna4nblx=',sumdvy); end.

Pascalabc.net 3.3.5, сборка 1659 от 09.04.2018 внимание! если программа не работает, обновите версию! begin   var (a,b): =readinteger2;   var s: =range(a,b).select(t-> t*t).sum;   if s< 100 then writeln('yes') else writeln('no') end.

Реши свою проблему, спроси otvet5GPT

  • Быстро
    Мгновенный ответ на твой вопрос
  • Точно
    Бот обладает знаниями во всех сферах
  • Бесплатно
    Задай вопрос и получи ответ бесплатно

Популярно: Информатика

Caktus Image

Есть вопросы?

  • Как otvet5GPT работает?

    otvet5GPT использует большую языковую модель вместе с базой данных GPT для обеспечения высококачественных образовательных результатов. otvet5GPT действует как доступный академический ресурс вне класса.
  • Сколько это стоит?

    Проект находиться на стадии тестирования и все услуги бесплатны.
  • Могу ли я использовать otvet5GPT в школе?

    Конечно! Нейросеть может помочь вам делать конспекты лекций, придумывать идеи в классе и многое другое!
  • В чем отличия от ChatGPT?

    otvet5GPT черпает академические источники из собственной базы данных и предназначен специально для студентов. otvet5GPT также адаптируется к вашему стилю письма, предоставляя ряд образовательных инструментов, предназначенных для улучшения обучения.

Подпишись на наш телеграмм канал

GTP TOP NEWS