Есть ответ 👍

1)-напечатайте таблицу соответствия между весом в фунтах и весом в килограммах (1 фунт = 400 грамм) для значений от 1 дщ 100 фунтов с шагом 1. все данные расположите в несколько столбцов так, чтобы они были видны на экране. 2)-напишите программу формирования массива размером 5*5, как типизированную константу. замените в нем все отрицательные значения элементов суммой значений элементов первой строки массива. выведите на экран исходный и измененный массив. 3)-сформулируйте массив содержащий 15 элементов с датчика случайных чисел. получите новый массив, каждый элемент которого равен увеличенному на заданное с клавиатуры число соответствующему элементу исходного массива. выведите на экран исходные и полученные результаты.

160
259
Посмотреть ответы 2

Ответы на вопрос:

katemurzik
4,8(76 оценок)

1) program gt; var a,i: integer; begin for i: =1 to 100 do begin writeln(i,' ',i*400); end; end.2)program gt; var a: array[1..100,1..100]of integer; i,j,s: integer; beginrandomize; for i: =1 to 5 dofor j: =1 to 5 doa[i,j]: =random(100)-50; s: =0; for j: =1 to 5 dos: =s+a[1,j]; for i: =1 to 5 dobeginfor j: =1 to 5 dowrite(a[i,j],' '); writeln; end; writeln; for i: =1 to 5 dobeginfor j: =1 to 5 dobeginif(a[i,j]< 0)then a[i,j]: =s; write(a[i,j],' '); end; writeln; end; end.3)program gt; var a,b: array[1..15]of integer; i,j,s: integer; beginrandomize; for i: =1 to 15 doa[i]: =random(100)-50; for i: =1 to 15 dobeginread(j); b[i]: =a[i]+j; end; for i: =1 to 15 dowrite(a[i],' '); writeln; for i: =1 to 15 dowrite(b[i],' '); end.

Форматирование текста - это изменение внешнего вида текста - размер, шрифт, стиль, ццвет и т.д.

Реши свою проблему, спроси otvet5GPT

  • Быстро
    Мгновенный ответ на твой вопрос
  • Точно
    Бот обладает знаниями во всех сферах
  • Бесплатно
    Задай вопрос и получи ответ бесплатно

Популярно: Информатика

Caktus Image

Есть вопросы?

  • Как otvet5GPT работает?

    otvet5GPT использует большую языковую модель вместе с базой данных GPT для обеспечения высококачественных образовательных результатов. otvet5GPT действует как доступный академический ресурс вне класса.
  • Сколько это стоит?

    Проект находиться на стадии тестирования и все услуги бесплатны.
  • Могу ли я использовать otvet5GPT в школе?

    Конечно! Нейросеть может помочь вам делать конспекты лекций, придумывать идеи в классе и многое другое!
  • В чем отличия от ChatGPT?

    otvet5GPT черпает академические источники из собственной базы данных и предназначен специально для студентов. otvet5GPT также адаптируется к вашему стилю письма, предоставляя ряд образовательных инструментов, предназначенных для улучшения обучения.

Подпишись на наш телеграмм канал

GTP TOP NEWS