Есть ответ 👍

Напишите программу для вычисления выражения. Паскаль.

154
313
Посмотреть ответы 2

Ответы на вопрос:

rustiuh
4,4(39 оценок)

Надеюсь тебе
Напишите программу для вычисления выражения. Паскаль.
maks312017
4,5(93 оценок)

program vidcvnjiod;

uses crt;

var p,a: real;

      m: integer;

begin

clrscr;

a: =1000;

p: =(a*2)/100;

m: =3;

repeat

a: =a+p;

m: =m+1;

until a> 1050;

m: =m mod 12;

case m of

0: writeln('декабрь');

1: writeln('январь');

2: writeln('февраль');

3: writeln('март');

4: writeln('апрель');

5: writeln('май');

6: writeln('июнь');

7: writeln('июль');

8: writeln('август');

9: writeln('сентябрь');

10: writeln('октябрь');

11: writeln('ноябрь');

readln;

end.

откомпиль, если ошибки, то исправь, но вроде не должно быть

в программе а=1000

отсчитывается процент

идет цикл пока сумма не больше 1050

прибавляется процент и месяц идет дальше

затем выбор месяца

 

Реши свою проблему, спроси otvet5GPT

  • Быстро
    Мгновенный ответ на твой вопрос
  • Точно
    Бот обладает знаниями во всех сферах
  • Бесплатно
    Задай вопрос и получи ответ бесплатно

Популярно: Информатика

Caktus Image

Есть вопросы?

  • Как otvet5GPT работает?

    otvet5GPT использует большую языковую модель вместе с базой данных GPT для обеспечения высококачественных образовательных результатов. otvet5GPT действует как доступный академический ресурс вне класса.
  • Сколько это стоит?

    Проект находиться на стадии тестирования и все услуги бесплатны.
  • Могу ли я использовать otvet5GPT в школе?

    Конечно! Нейросеть может помочь вам делать конспекты лекций, придумывать идеи в классе и многое другое!
  • В чем отличия от ChatGPT?

    otvet5GPT черпает академические источники из собственной базы данных и предназначен специально для студентов. otvet5GPT также адаптируется к вашему стилю письма, предоставляя ряд образовательных инструментов, предназначенных для улучшения обучения.

Подпишись на наш телеграмм канал

GTP TOP NEWS