Есть ответ 👍

Задание на С# Задание: Дан массив, состоящий из целых чисел. Нумерация элементов начинается с 0. Напишите программу, которая выведет элементы массива, номера которых четны (0, 2, 4...). Входные данные Сначала задано число N — количество элементов в массиве (1<=N<=100). Далее через пробел записаны N чисел — элементы массива. Массив состоит из целых чисел. Выходные данные Необходимо вывести все элементы массива с чётными номерами. Решение:
using System;
using System.IO;
namespace ConsoleApp2
{ class Program
{ static void Main(string[] args)
{ int a = Int32.Parse(Console.ReadLine());
string text = Console.ReadLine();
string[] arraystring = text.Split(new char[] { ' ' });
int[] arrayy = new int[a];
int b = 0;
for (int i = 0; i < a; i++) { b = Int32.Parse(arraystring[i]);
arrayy[i] = b;
if (i % 2 == 0) ;
{ Console.Write(arrayy[i] + " "); } } } } }

Оно почему то не работает, найдите ошибку

200
264
Посмотреть ответы 2

Ответы на вопрос:

bomicbomic
4,4(51 оценок)

C#

Задача не предполагает создание нового массива, в ней сказано "вывести все элементы массива с чётными номерами".

int a = Int32.Parse(Console.ReadLine()); string text = Console.ReadLine(); string[] array = text.Split(' '); for (int i = 0; i < a; i+=2) Console.Write(array[i] + " "); Console.WriteLine(); Console.ReadLine();

или можно используя System.Linq ("int a" даже лишняя):

int a = Int32.Parse(Console.ReadLine()); string text = Console.ReadLine(); string[] array = text.Split(' '); Console.WriteLine(string.Join(' ', array.Where((x,i) => i%2==0))); Console.ReadLine();

Пример работы:


Задание на С# Задание: Дан массив, состоящий из целых чисел. Нумерация элементов начинается с 0. Нап
Задание на С# Задание: Дан массив, состоящий из целых чисел. Нумерация элементов начинается с 0. Нап

1)всего бит - 1024*768*8

    всего байт 1024*768*8/8=1024*768(в байте 8 бит)

    всего киллобайт = 768 (кб =1024 байт)

2)

  44000гц=44кгц

  44000*60*8 - всего бит

  44000*60     - всего байт

  ответ 2640000

Реши свою проблему, спроси otvet5GPT

  • Быстро
    Мгновенный ответ на твой вопрос
  • Точно
    Бот обладает знаниями во всех сферах
  • Бесплатно
    Задай вопрос и получи ответ бесплатно

Популярно: Информатика

Caktus Image

Есть вопросы?

  • Как otvet5GPT работает?

    otvet5GPT использует большую языковую модель вместе с базой данных GPT для обеспечения высококачественных образовательных результатов. otvet5GPT действует как доступный академический ресурс вне класса.
  • Сколько это стоит?

    Проект находиться на стадии тестирования и все услуги бесплатны.
  • Могу ли я использовать otvet5GPT в школе?

    Конечно! Нейросеть может помочь вам делать конспекты лекций, придумывать идеи в классе и многое другое!
  • В чем отличия от ChatGPT?

    otvet5GPT черпает академические источники из собственной базы данных и предназначен специально для студентов. otvet5GPT также адаптируется к вашему стилю письма, предоставляя ряд образовательных инструментов, предназначенных для улучшения обучения.

Подпишись на наш телеграмм канал

GTP TOP NEWS