Есть ответ 👍

Определите, количество чисел K, для которых следующая программа выведет такой же результат, что и для K = 30:

#include
using namespace std;
int F(int x)
{
if (x < 3)
return 1;
else
return 2 * F(x - 1) + F(x - 2);
}
int main()
{
int i, k; i = 15;
cin >> k;
while (i > 0 && F(i) > k)
i = i - 1;
cout << i;
}

var i, k: integer;
function F(x:integer):integer;
begin if x < 3 then
F:= 1
else F:= 2*F(x-1) + F(x-2);
end;
begin
i := 15;
readln(K);
while (i > 0) and (F(i) > K) do
i:=i-1;
writeln(i);
end.

272
276
Посмотреть ответы 2

Ответы на вопрос:


24

Объяснение:

var

i,j,k: integer;

function F(x:integer):integer;

begin if x < 3 then

F:= 1

else F:= 2*F(x-1) + F(x-2);

end;

begin

for k:=15 to 50 do

begin

i := 15;

while (i > 0) and (F(i) > K) do

i:=i-1;

write(i,' ');

end;

end.


program xxx;

  var  a, b, c, s, p : real;

begin

  write('введите первое число а =');

  readln(a);

  write('введите второе число b = ');

  readln(b);

  write('введите треnmt число c = ');

  readln(c);

  s: = a + b + c;

  p: = a * b * c;

  writeln('сумма чисел =', s);

  writeln('произведение чисел =', p);

  readln

end.

Реши свою проблему, спроси otvet5GPT

  • Быстро
    Мгновенный ответ на твой вопрос
  • Точно
    Бот обладает знаниями во всех сферах
  • Бесплатно
    Задай вопрос и получи ответ бесплатно

Популярно: Информатика

Caktus Image

Есть вопросы?

  • Как otvet5GPT работает?

    otvet5GPT использует большую языковую модель вместе с базой данных GPT для обеспечения высококачественных образовательных результатов. otvet5GPT действует как доступный академический ресурс вне класса.
  • Сколько это стоит?

    Проект находиться на стадии тестирования и все услуги бесплатны.
  • Могу ли я использовать otvet5GPT в школе?

    Конечно! Нейросеть может помочь вам делать конспекты лекций, придумывать идеи в классе и многое другое!
  • В чем отличия от ChatGPT?

    otvet5GPT черпает академические источники из собственной базы данных и предназначен специально для студентов. otvet5GPT также адаптируется к вашему стилю письма, предоставляя ряд образовательных инструментов, предназначенных для улучшения обучения.

Подпишись на наш телеграмм канал

GTP TOP NEWS