Есть ответ 👍

С клавиатуры вводится 10 чисел (каждое в отдельной строке) - это числа возраста 10 детей.

Если возраст меньше 7, то это ребенок из детского сада.

Определите количество детсадовцев среди 10 детей.

Формат входных данных
10 положительных целых чисел (каждое в отдельной строке), не превышающих 100

Формат выходных данных
Одно число - ответ.

176
430
Посмотреть ответы 1

Ответы на вопрос:


Обозначим заработок за n дней как s(n). заработок по дням: 2, 5, 11, 23, 47. разница между членами последовательности: 3, 6, 12, 24 ( прогрессия). 3 = 2^1 + 2^0 6 = 2^2 + 2^1 12 = 2^3 + 2^2 24 = 2^4 + 2^3 2 + 5 + 11 + 23 + 47 = 2 + (2+3) + (2+3+3*2) + (2+3+3*2+3*2*2) + (2+3+3*2+3*2*2+3*2*2*2) = (2+s1) + (2+s2) + (2+s3) + (2+s4) s1, s2, s3, s4 - это суммы прогрессий с q=2 и b1=3 таким образом, s(n) = 2n + s1 + s2 + s3 + s4 + s_{n-1} = 2n + 3(2^1 - 1) + 3(2^2 - 1) + + 3(2^{n-1} - 1) = 2n + 3(2^1 - 1 + 2^2 - 1 + + 2^{n-1} - 1) = 2n + 3(2(2^{n-1} - 1) - n + 1) = 2n + 3(2^n - 1 - n) = 3*2^n - 3 - n на паскале заработок муравья за n дней можно посчитать так: 3*power(2, n) - 3 - n заработок в n-й день работы, причем n > = 2, так: 3*power(2, n - 1) - 1 uses math; var n, d, t: integer; begin readln(n); writeln('all days: ', 3*power(2, n) - 3 - n); writeln('in last day: ', 3*power(2, n - 1) - 1); end.

Реши свою проблему, спроси otvet5GPT

  • Быстро
    Мгновенный ответ на твой вопрос
  • Точно
    Бот обладает знаниями во всех сферах
  • Бесплатно
    Задай вопрос и получи ответ бесплатно

Популярно: Информатика

Caktus Image

Есть вопросы?

  • Как otvet5GPT работает?

    otvet5GPT использует большую языковую модель вместе с базой данных GPT для обеспечения высококачественных образовательных результатов. otvet5GPT действует как доступный академический ресурс вне класса.
  • Сколько это стоит?

    Проект находиться на стадии тестирования и все услуги бесплатны.
  • Могу ли я использовать otvet5GPT в школе?

    Конечно! Нейросеть может помочь вам делать конспекты лекций, придумывать идеи в классе и многое другое!
  • В чем отличия от ChatGPT?

    otvet5GPT черпает академические источники из собственной базы данных и предназначен специально для студентов. otvet5GPT также адаптируется к вашему стилю письма, предоставляя ряд образовательных инструментов, предназначенных для улучшения обучения.

Подпишись на наш телеграмм канал

GTP TOP NEWS