Есть ответ 👍

Напишите программу, которая получает с клавиатуры натуральное число и находит наибольшую цифру в его десятичной записи. Пример: Введите число? 311 Наибольшая цифра: 3

146
371
Посмотреть ответы 1

Ответы на вопрос:


// pascalabc.net 3.2, сборка 1353 от 27.11.2016 // внимание! если программа не работает, обновите версию! const   r=8.314; begin   writeln('расчет параметров газового состояния');   writeln('введите обозначение величины, которую хотите найти: ');   writeln('p - давление, m- масса газа, v - объем массы газа,');   writeln('t- термодинамическую температуру, иное - отказ');   var c: =readlnchar;   if pos(c,'ppmmvvtt')=0 then writeln('всего доброго! ')   else begin       var m1,p,v,m,t: real;       m1: =readreal('введите массу одного моля газа (кг/моль): ');       case c of       'p','p': begin           m: =readreal('введите массу газа (кг): ');           v: =readreal('введите объем массы газа (м3): ');           t: =readreal('введите термодинамическую температуру (к); ');           writeln('давление p составляет ',m*r*t/m1/v: 0: 5,' па')           end;       'm','m': begin           p: =readreal('введите давление газа p (па): ');           v: =readreal('введите объем массы газа (м3): ');           t: =readreal('введите термодинамическую температуру (к); ');           writeln('масса газа m составляет ',p*v*m1/r/t: 0: 5,' кг')           end;       'v','v': begin           p: =readreal('введите давление газа p (па): ');           m: =readreal('введите массу газа (кг): ');           t: =readreal('введите термодинамическую температуру (к); ');           writeln('объем массы газа v составляет ',m*r*t/m1/p: 0: 5,' м3')           end;       't','t': begin           p: =readreal('введите давление газа p (па): ');           m: =readreal('введите массу газа (кг): ');           v: =readreal('введите объем массы газа (м3): ');           writeln('термодинамическая температура составляет ',p*v*m1/m/r: 0: 1,' k')           end       end   end end. пример расчет параметров газового состояния введите обозначение величины, которую хотите найти: p - давление, m- масса газа, v - объем массы газа, t- термодинамическую температуру, иное - отказ m введите массу одного моля газа (кг/моль): 28e-3 введите давление газа p (па): 96360 введите объем массы газа (м3): 2e-3 введите термодинамическую температуру (к); 298 масса газа m составляет 0.00218 кг

Реши свою проблему, спроси otvet5GPT

  • Быстро
    Мгновенный ответ на твой вопрос
  • Точно
    Бот обладает знаниями во всех сферах
  • Бесплатно
    Задай вопрос и получи ответ бесплатно

Популярно: Информатика

Caktus Image

Есть вопросы?

  • Как otvet5GPT работает?

    otvet5GPT использует большую языковую модель вместе с базой данных GPT для обеспечения высококачественных образовательных результатов. otvet5GPT действует как доступный академический ресурс вне класса.
  • Сколько это стоит?

    Проект находиться на стадии тестирования и все услуги бесплатны.
  • Могу ли я использовать otvet5GPT в школе?

    Конечно! Нейросеть может помочь вам делать конспекты лекций, придумывать идеи в классе и многое другое!
  • В чем отличия от ChatGPT?

    otvet5GPT черпает академические источники из собственной базы данных и предназначен специально для студентов. otvet5GPT также адаптируется к вашему стилю письма, предоставляя ряд образовательных инструментов, предназначенных для улучшения обучения.

Подпишись на наш телеграмм канал

GTP TOP NEWS