Есть ответ 👍

Составьте программу , которая формирует массив из 40 случайных целых чисел от 0 до 20 и вычисляет: а) среднее арифметическое нечётных чисел б) сумму чисел, не превышающих 10 в) сумму чисел кратных 3 на экран выводятся исходные значения и результаты вычислений.

112
477
Посмотреть ответы 2

Ответы на вопрос:

neli2017
4,5(68 оценок)

Program task; var a: array [1..40] of integer; b: real; c, d, e, i: integer; begin randomize; for i : = 1 to 40 do a[i] : = random(20 + 1); writeln('массив: '); for i : = 1 to 40 do write(a[i], ' '); writeln; for i : = 1 to 40 do begin if a[i] mod 2 = 1 then begin b : = b + a[i]; c : = c + 1; end; if a[i] < = 10 then d : = d + a[i]; if a[i] mod 3 = 0 then e : = e + a[i]; end; writeln('среднее арифметическое нечётных чисел: ', (b / c): 2: 2); writeln('сумма чисел, не превышающих 10: ', d); writeln('сумма чисел кратных 3: ', e); readln; end.
Kadokawa
4,8(48 оценок)

что-то с названием русского писателя а4

Реши свою проблему, спроси otvet5GPT

  • Быстро
    Мгновенный ответ на твой вопрос
  • Точно
    Бот обладает знаниями во всех сферах
  • Бесплатно
    Задай вопрос и получи ответ бесплатно

Популярно: Информатика

Caktus Image

Есть вопросы?

  • Как otvet5GPT работает?

    otvet5GPT использует большую языковую модель вместе с базой данных GPT для обеспечения высококачественных образовательных результатов. otvet5GPT действует как доступный академический ресурс вне класса.
  • Сколько это стоит?

    Проект находиться на стадии тестирования и все услуги бесплатны.
  • Могу ли я использовать otvet5GPT в школе?

    Конечно! Нейросеть может помочь вам делать конспекты лекций, придумывать идеи в классе и многое другое!
  • В чем отличия от ChatGPT?

    otvet5GPT черпает академические источники из собственной базы данных и предназначен специально для студентов. otvet5GPT также адаптируется к вашему стилю письма, предоставляя ряд образовательных инструментов, предназначенных для улучшения обучения.

Подпишись на наш телеграмм канал

GTP TOP NEWS