Есть ответ 👍

Даны три одномерных массива. упорядочить их по возрастанию элементов. составить программу проверки, сколько раз повторяется заданное число в каждом массиве. результаты сохранить в одномерном массиве и элементы массива отсортировать по возрастанию даны три одномерных массива. упорядочить их по возрастанию элементов. составить программу проверки, сколько раз повторяется заданное число в каждом массиве. результаты сохранить в одномерном массиве и элементы массива отсортировать по возрастанию

181
417
Посмотреть ответы 2

Ответы на вопрос:


Программа рассчитана на то, что на экран выводится самый последний массив с результатами. uses crt; const p=5; r=5; s=5; var a: array[1..p] of integer; b: array[1..r] of integer; c: array[1..s] of integer; m: array[1..3] of integer; k,l,i,g,j,d,v,n: integer; begin readln(l);   writeln;   for i: =1 to p do readln(a[i]);     writeln;     for j: =1 to r do readln(b[j]);         writeln;         for g: =1 to s do readln(c[g]);         writeln;         for i: =1 to p-1 do repeat d: =0; if a[i]> a[i+1] then begin d: =1; a[i]: =a[i]+a[i+1]; a[i+1]: =a[i]-a[i+1]; a[i]: =a[i]-a[i+1]; end; until d=0; for j: =1 to r-1 do repeat d: =0; if b[j]> b[j+1] then begin d: =1; b[j]: =b[j]+b[j+1]; b[j+1]: =b[j]-b[j+1]; b[j]: =b[j]-b[j+1]; end; until d=0; for g: =1 to s-1 do repeat d: =0; if c[g]> c[g+1] then begin d: =1; c[g]: =c[g]+c[g+1]; c[g+1]: =c[g]-c[g+1]; c[g]: =c[g]-c[g+1]; end; until d=0; for i: =1 to p do if a[i]=l then inc(v); m[1]: =v; v: =0; for j: =1 to r do if b[j]=l then inc(v); m[2]: =v; v: =0; for g: =1 to s do if c[g]=l then inc(v); m[3]: =v; for n: =1 to 2 do repeat d: =0; if m[n]> m[n+1] then begin d: =1; m[n]: =m[n]+m[n+1]; m[n+1]: =m[n]-m[n+1]; m[n]: =m[n]-m[n+1]; end; until d=0; for n: =1 to 3 do writeln(m[n]); end.
Vanya2155
4,7(73 оценок)

ответ:

это вообще информатика?

Реши свою проблему, спроси otvet5GPT

  • Быстро
    Мгновенный ответ на твой вопрос
  • Точно
    Бот обладает знаниями во всех сферах
  • Бесплатно
    Задай вопрос и получи ответ бесплатно

Популярно: Информатика

Caktus Image

Есть вопросы?

  • Как otvet5GPT работает?

    otvet5GPT использует большую языковую модель вместе с базой данных GPT для обеспечения высококачественных образовательных результатов. otvet5GPT действует как доступный академический ресурс вне класса.
  • Сколько это стоит?

    Проект находиться на стадии тестирования и все услуги бесплатны.
  • Могу ли я использовать otvet5GPT в школе?

    Конечно! Нейросеть может помочь вам делать конспекты лекций, придумывать идеи в классе и многое другое!
  • В чем отличия от ChatGPT?

    otvet5GPT черпает академические источники из собственной базы данных и предназначен специально для студентов. otvet5GPT также адаптируется к вашему стилю письма, предоставляя ряд образовательных инструментов, предназначенных для улучшения обучения.

Подпишись на наш телеграмм канал

GTP TOP NEWS