Есть ответ 👍

35прошу ! опишите этот код. прям пошагово объясните. pascal abc
вот : написать программу, в которой пользователь вводит 5 чисел и нужно вывести максимальное число и минимальное. и поменять их местами.
например:
6
7
8
9
10
макс.- 10
мин.- 6
10
7
8
9
6

код:
program d;
var min,max,a : integer;
mas: array[1..5] of integer;
begin
for a: =1 to 5 do
begin
readln(mas[a]);
if mas[a]< =mas[min] then min: =a;
if mas[a]> =mas[max] then max: =a;
end;
writeln;
writeln (mas[max]);
for a: =1 to 5 do
if (a< > min)and(a< > max) then writeln (mas[a]);
writeln(mas[min]);
end.​

151
321
Посмотреть ответы 2

Ответы на вопрос:


ответ:

maxn = индекс макс значения в массиве , minn - миним индекс массива

через if мы по этапно сравниваем значения , если условия верны то , значения min/max меняется на текущее значения массива

объяснение:

program d;

var min,max,i,minn,maxn : integer;

mas: array[0..4] of integer;

begin

for i: =0 to 4 do

begin

  readln(mas[i]);

end;

min: =mas[0];

minn: =1;

maxn: =1;

max: =mas[0];

for i: =1 to 4 do

begin

  if min

  if max> mas[i] then begin maxn: =i; max: =mas[i] end;

end;

mas[maxn]: =min;

mas[minn]: =max;

for i: =0 to 4 do

writeln(mas[i]);

end.

Obcenceee
4,8(1 оценок)

Program znanija_12709446;     var  i : integer;       s : integer; begin      for i : = 1 to 19 do          if (i mod 2 < > 0) then                s : = s + i*i;       print(s); end.

Реши свою проблему, спроси otvet5GPT

  • Быстро
    Мгновенный ответ на твой вопрос
  • Точно
    Бот обладает знаниями во всех сферах
  • Бесплатно
    Задай вопрос и получи ответ бесплатно

Популярно: Информатика

Caktus Image

Есть вопросы?

  • Как otvet5GPT работает?

    otvet5GPT использует большую языковую модель вместе с базой данных GPT для обеспечения высококачественных образовательных результатов. otvet5GPT действует как доступный академический ресурс вне класса.
  • Сколько это стоит?

    Проект находиться на стадии тестирования и все услуги бесплатны.
  • Могу ли я использовать otvet5GPT в школе?

    Конечно! Нейросеть может помочь вам делать конспекты лекций, придумывать идеи в классе и многое другое!
  • В чем отличия от ChatGPT?

    otvet5GPT черпает академические источники из собственной базы данных и предназначен специально для студентов. otvet5GPT также адаптируется к вашему стилю письма, предоставляя ряд образовательных инструментов, предназначенных для улучшения обучения.

Подпишись на наш телеграмм канал

GTP TOP NEWS