Есть ответ 👍

(составить программы в паскале): напишите программу, которая ввод данных в одномерный целочисленный массив осуществляет посредством цикла , а вывод – (в скобках указана размерность массива): увеличить каждый третий элемент массива в 2 раза (12)напишите программу, в которой нужно для каждой строки двухмерного массива 5 на 4 определить максимальное значение

297
404
Посмотреть ответы 2

Ответы на вопрос:


var

a: array[1..5,1..4]of integer;

max,i,j: integer;

begin

for i: =1 to 5 do begin

for j: =1 to 4 do begin

a[i,j]: =random(10);

write(a[i,j],' ');

end;

writeln;

end;

for i: =1 to 5 do begin

max: =a[i,1];

for j: =1 to 4 do

if a[i,j]> max then max: =a[i,j];

writeln(max);

end;

end.

2


Если задание для Кумира, то вот программа:

использовать Робот

алг

нач

нц пока сверху стена

влево

кц

вверх

нц пока справа стена

вверх

кц

вправо

нц пока снизу стена

закрасить

вправо

кц

кон

Объяснение:

Реши свою проблему, спроси otvet5GPT

  • Быстро
    Мгновенный ответ на твой вопрос
  • Точно
    Бот обладает знаниями во всех сферах
  • Бесплатно
    Задай вопрос и получи ответ бесплатно

Популярно: Информатика

Caktus Image

Есть вопросы?

  • Как otvet5GPT работает?

    otvet5GPT использует большую языковую модель вместе с базой данных GPT для обеспечения высококачественных образовательных результатов. otvet5GPT действует как доступный академический ресурс вне класса.
  • Сколько это стоит?

    Проект находиться на стадии тестирования и все услуги бесплатны.
  • Могу ли я использовать otvet5GPT в школе?

    Конечно! Нейросеть может помочь вам делать конспекты лекций, придумывать идеи в классе и многое другое!
  • В чем отличия от ChatGPT?

    otvet5GPT черпает академические источники из собственной базы данных и предназначен специально для студентов. otvet5GPT также адаптируется к вашему стилю письма, предоставляя ряд образовательных инструментов, предназначенных для улучшения обучения.

Подпишись на наш телеграмм канал

GTP TOP NEWS