Есть ответ 👍

Есть ли способы максимально оптимизировать решение данной так, чтобы решать её не путём какого-либо перебора, а быстро просчитать ответ? найдите наименьшее натуральное число, которое нужно подать на вход алгоритма, чтобы в результате были выведены числа 3 и 7.

109
461
Посмотреть ответы 1

Ответы на вопрос:

26032004й
4,8(38 оценок)

Решение Pascal

Delphi/Pascal

program Case5;

var

 N,A,B:Integer;

begin

 Write('Введите номер действия: ');

 Readln(N);

 Write('Введите число A: ');

 Readln(A);

 Write('Введите число B: ');

 Readln(B);

 

 Case N of

   1: Writeln(A+B);

   2: Writeln(A-B);

   3: Writeln(A*B);

   4: Writeln(A/B);

 end;

end.

1

2

3

4

5

6

7

8

9

10

11

12

13

14

15

16

17

18

program Case5;

var

 N,A,B:Integer;

begin

 Write('Введите номер действия: ');

 Readln(N);

 Write('Введите число A: ');

 Readln(A);

 Write('Введите число B: ');

 Readln(B);

 

 Case N of

   1: Writeln(A+B);

   2: Writeln(A-B);

   3: Writeln(A*B);

   4: Writeln(A/B);

 end;

end.

 

Решение C

C

#include <stdio.h>

 

int main(void)

{

  system("chcp 1251");

  int n;

  float a,b;

  printf("N:") ;

  scanf ("%i", &n);

  printf("A:") ;

  scanf ("%f", &a);

  printf("B:") ;

  scanf ("%f", &b);

 

  switch (n) {

  case 1:

      printf("%f\n",a+b) ;

      break;

  case 2:

      printf("%f\n",a-b) ;

      break;

  case 3:

      printf("%f\n",a*b) ;

      break;

  case 4:

      printf("%f\n",a/b) ;

      break;

  }

  return 0;

}

1

2

3

4

5

6

7

8

9

10

11

12

13

14

15

16

17

18

19

20

21

22

23

24

25

26

27

28

29

30

#include <stdio.h>

 

int main(void)

{

  system("chcp 1251");

  int n;

  float a,b;

  printf("N:") ;

  scanf ("%i", &n);

  printf("A:") ;

  scanf ("%f", &a);

  printf("B:") ;

  scanf ("%f", &b);

 

  switch (n) {

  case 1:

      printf("%f\n",a+b) ;

      break;

  case 2:

      printf("%f\n",a-b) ;

      break;

  case 3:

      printf("%f\n",a*b) ;

      break;

  case 4:

      printf("%f\n",a/b) ;

      break;

  }

  return 0;

}

Объяснение:

Реши свою проблему, спроси otvet5GPT

  • Быстро
    Мгновенный ответ на твой вопрос
  • Точно
    Бот обладает знаниями во всех сферах
  • Бесплатно
    Задай вопрос и получи ответ бесплатно

Популярно: Информатика

Caktus Image

Есть вопросы?

  • Как otvet5GPT работает?

    otvet5GPT использует большую языковую модель вместе с базой данных GPT для обеспечения высококачественных образовательных результатов. otvet5GPT действует как доступный академический ресурс вне класса.
  • Сколько это стоит?

    Проект находиться на стадии тестирования и все услуги бесплатны.
  • Могу ли я использовать otvet5GPT в школе?

    Конечно! Нейросеть может помочь вам делать конспекты лекций, придумывать идеи в классе и многое другое!
  • В чем отличия от ChatGPT?

    otvet5GPT черпает академические источники из собственной базы данных и предназначен специально для студентов. otvet5GPT также адаптируется к вашему стилю письма, предоставляя ряд образовательных инструментов, предназначенных для улучшения обучения.

Подпишись на наш телеграмм канал

GTP TOP NEWS