Есть ответ 👍

Кто шарит в pascal. составить программу приближенного вычисления определенного интеграла, используя формулы численного интегрирования: формулу левых прямоугольников.

282
350
Посмотреть ответы 2

Ответы на вопрос:


пусть l=x_0</p><p>[tex]\displaystyle \int_a^b f({i=0}^{n-1} f(x_i)(x_{i+1}-x_i)

часто выбирают равномерное разбиение, в котором все точки расположены на одинаковом расстоянии h = (b - a) / n, при этом x_i=a+ih.

реализация (pascalabc.net): функция int_lr принимает подинтегральную функцию, левую и правую границы отрезка интегрирования и количество отрезков в разбиения. в основной программе интеграл вычисляется для n = 1, 2, 4, 8, 1024, выводится n, результат численного интегрирования и разность между полученным значением и точным значением интеграла. можно заметить, что при увеличении n в 2 раза ошибка уменьшается примерно в 2 раза.

function int_lr(f: real-> real; l, r: real; n: integer): real;

begin

  var h : = (r - l) / n;

  var s : = 0.to(n - 1).select(i -> f(l + i * ;

  result : = s * h;

end;

const exact = 1250 / 3;

begin

  var n : = 1;

  for var _ : = 1 to 11 do

  begin

    var int : = int_lr(x -> (x - 5) ** 2 * (10 - x), 0, 10, n);

    writeln(n: 4, int: 9: 3, abs(int - exact): 9: 3);

    n : = 2 * n;

  end;

end.

вывод программы:

  1 2500.000 2083.333

  2 1250.000   833.333

  4   781.250   364.583

  8   585.938   169.271

  16   498.047   81.380

  32   456.543   39.876

  64   436.401   19.735

128   426.483     9.816

256   421.562     4.896

512   419.111     2.445

1024   417.888     1.221


513

Объяснение:

мди

Реши свою проблему, спроси otvet5GPT

  • Быстро
    Мгновенный ответ на твой вопрос
  • Точно
    Бот обладает знаниями во всех сферах
  • Бесплатно
    Задай вопрос и получи ответ бесплатно

Популярно: Информатика

Caktus Image

Есть вопросы?

  • Как otvet5GPT работает?

    otvet5GPT использует большую языковую модель вместе с базой данных GPT для обеспечения высококачественных образовательных результатов. otvet5GPT действует как доступный академический ресурс вне класса.
  • Сколько это стоит?

    Проект находиться на стадии тестирования и все услуги бесплатны.
  • Могу ли я использовать otvet5GPT в школе?

    Конечно! Нейросеть может помочь вам делать конспекты лекций, придумывать идеи в классе и многое другое!
  • В чем отличия от ChatGPT?

    otvet5GPT черпает академические источники из собственной базы данных и предназначен специально для студентов. otvet5GPT также адаптируется к вашему стилю письма, предоставляя ряд образовательных инструментов, предназначенных для улучшения обучения.

Подпишись на наш телеграмм канал

GTP TOP NEWS