Есть ответ 👍

Написать программу (в паскале) , которая вводит с клавиатуры 5 дробных чисел и вычисляет их среднее арифметическое.рекомендуемый вид экрана во время работы программы ниже. данные, введенные пользователем выделены полужирным шрифтом.вычисление среднего арифметического последовательности дробных чисел. после ввода каждого числа нажимайте . -> 5.4 -> 7.8 -> 3.0 -> 1.5 -> 2.3 среднее арифмитическое введенной последовательности: 4. 00 для завершения работы программы нажмите < enter> .

231
383
Посмотреть ответы 3

Ответы на вопрос:

Kseniya006
4,4(100 оценок)

var i: integer;

var a   : array[1..5] of real;

begin

for i in [1..5] do

    begin

    write('-> ');

    readln(a[i]);

end;

writeln((a[1]+a[2]+a[3]+a[4]+a[5])/5: 0: 2);

end.


program dgh;

var

a,b: real;

i: integer;

begin

b: =0;

for i: =1 to 5 do

begin

write ('-> '); readln (a);

b: =b+a;

end;

write('среднее арифметическое введенной последовательности: ');

write (b/5: 0: 2);

readln;

end.


// c++ #include < iostream> int main() {   float arr[100], sum = 0;   int n = 0;   std: : cin > > n;   for (int i = 0; i < n; i++) {     std: : cin > > arr[i];     if (arr[i] > 0)       sum += arr[i];   }   std: : cout < < sum;   return 0; } пример ввода: 4 2.7 -1.3 10.0 0.0 пример вывода: 12.7

Реши свою проблему, спроси otvet5GPT

  • Быстро
    Мгновенный ответ на твой вопрос
  • Точно
    Бот обладает знаниями во всех сферах
  • Бесплатно
    Задай вопрос и получи ответ бесплатно

Популярно: Информатика

Caktus Image

Есть вопросы?

  • Как otvet5GPT работает?

    otvet5GPT использует большую языковую модель вместе с базой данных GPT для обеспечения высококачественных образовательных результатов. otvet5GPT действует как доступный академический ресурс вне класса.
  • Сколько это стоит?

    Проект находиться на стадии тестирования и все услуги бесплатны.
  • Могу ли я использовать otvet5GPT в школе?

    Конечно! Нейросеть может помочь вам делать конспекты лекций, придумывать идеи в классе и многое другое!
  • В чем отличия от ChatGPT?

    otvet5GPT черпает академические источники из собственной базы данных и предназначен специально для студентов. otvet5GPT также адаптируется к вашему стилю письма, предоставляя ряд образовательных инструментов, предназначенных для улучшения обучения.

Подпишись на наш телеграмм канал

GTP TOP NEWS