Есть ответ 👍

Мне ! решить 2 по ивт в паскале: 1)составить программу вычисления в массиве a(n) произведения нечетных элементов 2)составьте программу вычисления в массиве b(n) максимального среди отрицательных элементов и его номера. заранее огромное ! нужно!

300
500
Посмотреть ответы 2

Ответы на вопрос:


Var a: array [0..10] of integer;     i, m: integer; begin       m : = 1;             for i : = 0 to 10 do       begin           a[i] : = random(50) - 25;           writeln('[', i, '] => ', a[i]);       end;       for i : = 0 to 10 do           if (a[i] mod 2 = 1) then m : = m * a[i];       writeln(m); end.2)var a: array [0..10] of integer;     i, m: integer; begin      for i : = 0 to 10 do      begin          a[i] : = random(50) - 25;           writeln('[', i, '] => ', a[i]);       end;             for i : = 0 to 10 do          if ((a[i] > a[m]) and (a[i] < 0)) then            m : = i;       writeln('[', m, '] => ', a[m]); end.можно и меньше циклов, это я для наглядности, чтобы всё не смешивалось =)
LollyOgry
4,4(40 оценок)

Если число в двоичной, то добавим ему незначащих нулей:

00001010-ответ

Реши свою проблему, спроси otvet5GPT

  • Быстро
    Мгновенный ответ на твой вопрос
  • Точно
    Бот обладает знаниями во всех сферах
  • Бесплатно
    Задай вопрос и получи ответ бесплатно

Популярно: Информатика

Caktus Image

Есть вопросы?

  • Как otvet5GPT работает?

    otvet5GPT использует большую языковую модель вместе с базой данных GPT для обеспечения высококачественных образовательных результатов. otvet5GPT действует как доступный академический ресурс вне класса.
  • Сколько это стоит?

    Проект находиться на стадии тестирования и все услуги бесплатны.
  • Могу ли я использовать otvet5GPT в школе?

    Конечно! Нейросеть может помочь вам делать конспекты лекций, придумывать идеи в классе и многое другое!
  • В чем отличия от ChatGPT?

    otvet5GPT черпает академические источники из собственной базы данных и предназначен специально для студентов. otvet5GPT также адаптируется к вашему стилю письма, предоставляя ряд образовательных инструментов, предназначенных для улучшения обучения.

Подпишись на наш телеграмм канал

GTP TOP NEWS