Есть ответ 👍

Написать программу вычисляющую сумму 12 элементов одномерного массива, заданного случайным образом.

178
383
Посмотреть ответы 2

Ответы на вопрос:

alicaraut
4,7(10 оценок)

var a: array[1..12] of integer;

i,s: integer;

begin

for i: =1 to 12 do

begin

a[i]: =random(100);

s: =s+a[i];

write (a[i],' ')

end;

writeln;

write (s)

end.


объяснение:

в таблице указаны расстояния между соседними станциями. значит станции для которых значения являются соседними. нужно для каждой таблицы найти все возможные маршруты и посчитать их длину.

поиск маршрутов начинать надо со станции а.

например из первой таблицы следует, что станция а соседствует со станциями в и е. станция в со станцией d, а та со станцией f. станция е тоже соседствует со станцией f, но из e в f можно добраться ещё и через c.

итого по первой таблице получается 3 маршрута.

a→b→d→f

a→e→f

a→e→c→f

расстояния берёшь из таблицы и складываешь. получается, что длины всех трёх маршрутов равны 10. то есть не подходит.

подобным образом проверяешь остальные таблицы.

Реши свою проблему, спроси otvet5GPT

  • Быстро
    Мгновенный ответ на твой вопрос
  • Точно
    Бот обладает знаниями во всех сферах
  • Бесплатно
    Задай вопрос и получи ответ бесплатно

Популярно: Информатика

Caktus Image

Есть вопросы?

  • Как otvet5GPT работает?

    otvet5GPT использует большую языковую модель вместе с базой данных GPT для обеспечения высококачественных образовательных результатов. otvet5GPT действует как доступный академический ресурс вне класса.
  • Сколько это стоит?

    Проект находиться на стадии тестирования и все услуги бесплатны.
  • Могу ли я использовать otvet5GPT в школе?

    Конечно! Нейросеть может помочь вам делать конспекты лекций, придумывать идеи в классе и многое другое!
  • В чем отличия от ChatGPT?

    otvet5GPT черпает академические источники из собственной базы данных и предназначен специально для студентов. otvet5GPT также адаптируется к вашему стилю письма, предоставляя ряд образовательных инструментов, предназначенных для улучшения обучения.

Подпишись на наш телеграмм канал

GTP TOP NEWS