Есть ответ 👍

Написать программу вычисления среднего арифметическое трех чисел с клавиатуры результат вывести с четырьмя знаками после запятой

294
497
Посмотреть ответы 2

Ответы на вопрос:

ааа512
4,6(7 оценок)

Pascal: var a,b,c: real; begin   write ('number 1: ');   readln (a);   write ('number 2: ');   readln (b);   write ('number 3: ');   readln (c);   writeln ('srednee: ',(a+b+c)/3: 0: 4);   readln; end. c++: #include < iostream> #include < iomanip> using namespace std; int main() {     float a,b,c;     cout.setf(std: : ios_base: : fixed,std: : ios_base: : floatfield);       cout < < "number 1: ";     cin > > a;             cout < < "number 2: ";     cin > > b;     cout < < "number 3: ";     cin > > c; cout.precision(4);     cout < < "srednee: " < < (a+b+c)/3 < < endl;     return 0; }

var

a : integer; flag : byte; s : string;

function hextodec (s : string) : integer; var i, d, dig : integer; res : integer; begin d : = 1; res : = 0; for i : = length (s) downto 1 do begin dig : = ord (s[i]); if dig < 58 then res : = res + (dig - 48) * d else res : = res + (dig - 55) * d; d : = d * 16; end; hextodec : = res; end;

function dectohex (a : integer) : string; var dig : integer; c : char; res : string; begin res : = ''; repeat dig : = a mod 16; if dig < 10 then c : = chr (dig + 48) else c : = chr (dig + 55); res : = res + c; a : = a div 16; until a = 0; dectohex : = res; end;

function revert (s : string) : string; var i : integer; r : string; begin r : = ''; for i : = length (s) downto 1 do r : = r + s[i]; revert : = r; end;

begin writeln ('введите систему счисления, в которую переводим'); readln (flag); if (flag = 16) then begin writeln ('введите число в десятичной системе счисления'); readln (a); writeln (revert (dectohex (; end else if (flag = 10) then begin writeln ('введите число в шестнадцатиричной системе счисления'); readln (s); writeln (hextodec (s)); end else writeln ('ошибка : неверная система счисления'); readln; end.

Реши свою проблему, спроси otvet5GPT

  • Быстро
    Мгновенный ответ на твой вопрос
  • Точно
    Бот обладает знаниями во всех сферах
  • Бесплатно
    Задай вопрос и получи ответ бесплатно

Популярно: Информатика

Caktus Image

Есть вопросы?

  • Как otvet5GPT работает?

    otvet5GPT использует большую языковую модель вместе с базой данных GPT для обеспечения высококачественных образовательных результатов. otvet5GPT действует как доступный академический ресурс вне класса.
  • Сколько это стоит?

    Проект находиться на стадии тестирования и все услуги бесплатны.
  • Могу ли я использовать otvet5GPT в школе?

    Конечно! Нейросеть может помочь вам делать конспекты лекций, придумывать идеи в классе и многое другое!
  • В чем отличия от ChatGPT?

    otvet5GPT черпает академические источники из собственной базы данных и предназначен специально для студентов. otvet5GPT также адаптируется к вашему стилю письма, предоставляя ряд образовательных инструментов, предназначенных для улучшения обучения.

Подпишись на наш телеграмм канал

GTP TOP NEWS