Есть ответ 👍

Составить программу - конвертер, которая запрашивает тип единицы измерения времени: 1 - секунда, 2 - минута, 3 - час, 4 - сутки, а также число - значение в этой единице измерения времени и переводит данное число во все остальные единицы измерения времени. ввод чисел заканчивается нажатием клавиши 0. протокол работы программы: выберите тип единицы измерения времени: 1 - секунда, 2 - минута, 3 - час, 4 - сутки, 0 - выход. 1 введите значение этой единицы времени: 3600 ответ: 3600 сек = 60 мин = 1 час = 0,042 суток выберите тип единицы измерения времени: 1 - секунда, 2 - минута, 3 - час, 4 - сутки, 0 - выход. 4 введите значение этой единицы времени: 1 ответ: 1 суток = 24 час = 1440 мин = 86 400 сек выберите тип единицы измерения времени: 1 - секунда, 2 - минута, 3 - час, 4 - сутки, 0 - выход. 0 пока!

228
386
Посмотреть ответы 2

Ответы на вопрос:

dylanboy
4,6(30 оценок)

Var a,r: integer; begin writeln('выберите тип единицы измерения времени: 1 - секунда, 2 - минута, 3 - час, 4 - сутки, 0 - выход.'); readln(r); while r< > 0 do     begin     write('введите значение этой единицы времени: ');     readln(a);     case r of     1: writeln(a,' сек = ',(a/60): 0: 3,' мин = ',(a/3600): 0: 3,' ч = ',(a/86400): 0: 3,' сут');     2: writeln(a,' мин = ',(a/60): 0: 3,' ч = ',(a/1440): 0: 3,' сут = ',a*60,' сек');     3: writeln(a,' ч = ',(a/24): 0: 3,' сут = ',a*3600,' сек = ',a*60,' мин');     4: writeln(a,' сут = ',a*24,' ч = ',a*1440,' мин = ',a*86400,' сек');     end;     writeln;     writeln('выберите тип единицы измерения времени: 1 - секунда, 2 - минута, 3 - час, 4 - сутки, 0 - выход.');     readln(r);     end; end.
tyler02169
4,8(100 оценок)

тип входных,то есть вводимых данных - integer(целые числа).

тип выходных,то есть выводимых данных будет real,так как при нахождении среднего арифметического числа мы делим их сумму на 3.

Реши свою проблему, спроси otvet5GPT

  • Быстро
    Мгновенный ответ на твой вопрос
  • Точно
    Бот обладает знаниями во всех сферах
  • Бесплатно
    Задай вопрос и получи ответ бесплатно

Популярно: Информатика

Caktus Image

Есть вопросы?

  • Как otvet5GPT работает?

    otvet5GPT использует большую языковую модель вместе с базой данных GPT для обеспечения высококачественных образовательных результатов. otvet5GPT действует как доступный академический ресурс вне класса.
  • Сколько это стоит?

    Проект находиться на стадии тестирования и все услуги бесплатны.
  • Могу ли я использовать otvet5GPT в школе?

    Конечно! Нейросеть может помочь вам делать конспекты лекций, придумывать идеи в классе и многое другое!
  • В чем отличия от ChatGPT?

    otvet5GPT черпает академические источники из собственной базы данных и предназначен специально для студентов. otvet5GPT также адаптируется к вашему стилю письма, предоставляя ряд образовательных инструментов, предназначенных для улучшения обучения.

Подпишись на наш телеграмм канал

GTP TOP NEWS