Есть ответ 👍

Составьте программу вычисления произведения нечетных чисел от 11 до 43 через while

126
272
Посмотреть ответы 2

Ответы на вопрос:

olga638
4,8(38 оценок)

Program f1; var p,x: integer; begin p: =1; x: =11; while x< = 43 do begin p: =p*x; x: =x+2; end; writeln(p); end.

ответ:

37₁₀ = 100101₂

37₁₀ = 45₈

объяснение:

37₁₀ = 1*2⁰ + 0*2¹ + 1*2² + 0*2³ + 0*2⁴ + 1*2⁵ = 100101₂

37₁₀ = 5*8⁰ + 4*8¹ = 45₈

100101₂ = 1*2⁰ + 0*2¹ + 1*2² + 0*2³ + 0*2⁴ + 1*2⁵ = 37₁₀

45₈ = 5*8⁰ + 4*8¹ = 37₁₀

Реши свою проблему, спроси otvet5GPT

  • Быстро
    Мгновенный ответ на твой вопрос
  • Точно
    Бот обладает знаниями во всех сферах
  • Бесплатно
    Задай вопрос и получи ответ бесплатно

Популярно: Информатика

Caktus Image

Есть вопросы?

  • Как otvet5GPT работает?

    otvet5GPT использует большую языковую модель вместе с базой данных GPT для обеспечения высококачественных образовательных результатов. otvet5GPT действует как доступный академический ресурс вне класса.
  • Сколько это стоит?

    Проект находиться на стадии тестирования и все услуги бесплатны.
  • Могу ли я использовать otvet5GPT в школе?

    Конечно! Нейросеть может помочь вам делать конспекты лекций, придумывать идеи в классе и многое другое!
  • В чем отличия от ChatGPT?

    otvet5GPT черпает академические источники из собственной базы данных и предназначен специально для студентов. otvet5GPT также адаптируется к вашему стилю письма, предоставляя ряд образовательных инструментов, предназначенных для улучшения обучения.

Подпишись на наш телеграмм канал

GTP TOP NEWS