Есть ответ 👍

Решить двумя способами.напишите программу, которая получает с клавиатуры натуральное число и определяет, сколько раз в его десятичной записи встречается цифра 1. пример: введите число? 311 единиц: 2

264
323
Посмотреть ответы 3

Ответы на вопрос:


Program n1; var num,k: integer; begin write('введите число '); readln(num); k: =0; while num< > 0 do begin if abs(num mod 10)=1 then k: =k+1; num: =num div 10; end; writeln('единиц: ',k); end.

//pascalabc.net 3.2 begin var n: =readinteger('введите число: '); var count: =0; repeat if abs(n mod 10)=1 then count+=1; n: =n div 10; until n=0; write ('единиц: ', count); end.

Галерея,плай музыка,сообщение и тд..........

Реши свою проблему, спроси otvet5GPT

  • Быстро
    Мгновенный ответ на твой вопрос
  • Точно
    Бот обладает знаниями во всех сферах
  • Бесплатно
    Задай вопрос и получи ответ бесплатно

Популярно: Информатика

Caktus Image

Есть вопросы?

  • Как otvet5GPT работает?

    otvet5GPT использует большую языковую модель вместе с базой данных GPT для обеспечения высококачественных образовательных результатов. otvet5GPT действует как доступный академический ресурс вне класса.
  • Сколько это стоит?

    Проект находиться на стадии тестирования и все услуги бесплатны.
  • Могу ли я использовать otvet5GPT в школе?

    Конечно! Нейросеть может помочь вам делать конспекты лекций, придумывать идеи в классе и многое другое!
  • В чем отличия от ChatGPT?

    otvet5GPT черпает академические источники из собственной базы данных и предназначен специально для студентов. otvet5GPT также адаптируется к вашему стилю письма, предоставляя ряд образовательных инструментов, предназначенных для улучшения обучения.

Подпишись на наш телеграмм канал

GTP TOP NEWS