Есть ответ 👍

Уровень b. m. две одинаковые цифры рядом напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). входные данные входная строка содержит одно натуральное число. выходные данные программа должна вывести слово 'yes', если в числе есть две одинаковые цифры, стоящие рядом, и слово 'no', если такой пары цифр нет. примеры входные данные 5221 выходные данные yes входные данные 1232 выходные данные no уровень c. o. две одинаковые цифры напишите программу, которая определяет, верно ли, что введённое число содержит по крайней мере две одинаковых цифры, возможно, не стоящие рядом (как, например, 212). входные данные входная строка содержит одно натуральное число. выходные данные программа должна вывести слово 'yes', если в числе есть две одинаковые цифры, и слово 'no', если такой пары цифр нет. примеры входные данные 212 выходные данные yes входные данные 12345 выходные данные no

102
131
Посмотреть ответы 2

Ответы на вопрос:


// pascalabc.net 3.2, сборка 1381 от 04.02.2017 // внимание! если программа не работает, обновите версию! м begin   var a: =readinteger.tostring.adjacentgroup;   var f: =false;   foreach var g in a do       if g.count> 1 then begin           write('yes'); f: =true; break       end;   if not f then write('no')   end. примеры 5221 yes 1232 no о begin   var s: =readinteger.tostring;   if s.length< > (s.distinct).count then write('yes')   else write('no')  end. примеры 212 yes 12345 no
efimovan
4,5(54 оценок)

ответ:

объяснение:

328

Реши свою проблему, спроси otvet5GPT

  • Быстро
    Мгновенный ответ на твой вопрос
  • Точно
    Бот обладает знаниями во всех сферах
  • Бесплатно
    Задай вопрос и получи ответ бесплатно

Популярно: Информатика

Caktus Image

Есть вопросы?

  • Как otvet5GPT работает?

    otvet5GPT использует большую языковую модель вместе с базой данных GPT для обеспечения высококачественных образовательных результатов. otvet5GPT действует как доступный академический ресурс вне класса.
  • Сколько это стоит?

    Проект находиться на стадии тестирования и все услуги бесплатны.
  • Могу ли я использовать otvet5GPT в школе?

    Конечно! Нейросеть может помочь вам делать конспекты лекций, придумывать идеи в классе и многое другое!
  • В чем отличия от ChatGPT?

    otvet5GPT черпает академические источники из собственной базы данных и предназначен специально для студентов. otvet5GPT также адаптируется к вашему стилю письма, предоставляя ряд образовательных инструментов, предназначенных для улучшения обучения.

Подпишись на наш телеграмм канал

GTP TOP NEWS