Есть ответ 👍

Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). входные данные входная строка содержит одно натуральное число. выходные данные программа должна вывести слово 'yes', если в числе есть две одинаковые цифры, стоящие рядом, и слово 'no', если такой пары цифр нет. примеры входные данные 5221 выходные данные yes входные данные 1232 выходные данные no

109
270
Посмотреть ответы 2

Ответы на вопрос:

maloypipos
4,8(100 оценок)

Program n1; const ny: array[boolean] of string[3] = ('no', 'yes'); var n: longint; b: boolean; begin write('n = '); readln(n); n : = abs(n); b : = false; while n > 9 do begin b : = n mod 10 = n mod 100 div 10; if b then break; n : = n div 10 end; writeln(ny[b]); readln end.

Var side : integer; begin readln(side); writeln(side * 4); end.

Реши свою проблему, спроси otvet5GPT

  • Быстро
    Мгновенный ответ на твой вопрос
  • Точно
    Бот обладает знаниями во всех сферах
  • Бесплатно
    Задай вопрос и получи ответ бесплатно

Популярно: Информатика

Caktus Image

Есть вопросы?

  • Как otvet5GPT работает?

    otvet5GPT использует большую языковую модель вместе с базой данных GPT для обеспечения высококачественных образовательных результатов. otvet5GPT действует как доступный академический ресурс вне класса.
  • Сколько это стоит?

    Проект находиться на стадии тестирования и все услуги бесплатны.
  • Могу ли я использовать otvet5GPT в школе?

    Конечно! Нейросеть может помочь вам делать конспекты лекций, придумывать идеи в классе и многое другое!
  • В чем отличия от ChatGPT?

    otvet5GPT черпает академические источники из собственной базы данных и предназначен специально для студентов. otvet5GPT также адаптируется к вашему стилю письма, предоставляя ряд образовательных инструментов, предназначенных для улучшения обучения.

Подпишись на наш телеграмм канал

GTP TOP NEWS