Есть ответ 👍

Составить программу для нахождения суммы всех нечетных целых чисел от 11 до 83

232
402
Посмотреть ответы 2

Ответы на вопрос:

sapro95
4,7(62 оценок)

Var i,n: integer; begin n: =0; for i: = 11 to 83 do if i mod 2=0 then n: =n else  begin  n: =n+i; writeln('i=', i); end; write ('sum=',n); end. 

1) absolute - директива для адреса переменной.например: var a : integer absolute $0040: $0002; //сеегмент: смещение

2) asm - директива для ассемблерных вставок. используется в критичных участках кода. пример:

begin asm xor ax, ax endend.

3)конструктор и деструктор нужны для создания и уничтожения экземпляра класса.существуют конструкторы/деструкторы по умолчанию, но если мы хотим заменить его своим, то используются constructor/destructor.пишется просто - вместо function/procedure пишется constructor/destructor, ну и в классе прописывается.type ooo = class public a, b : integer; constructor create (x, y : integer); end;

constructor ooo.create (x, y : integer); begin a : = x; b : = y; end;

4) implementation - в модуле обозначает начало исполняемой части, то есть там сами функции, процедуры и инициализация модуля.нужна, разумеется, чтобы отделить части модуля друг от друга.

пример модуля:

unit embler;

interface

procedure adds (x,y: integer, var z: integer);

implementation procedure addd (x,y: integer, var z: integer); begin z : = 2 * x + y; end; end.

5) например, graph - позволяет работать с графикой,math - функции, windows - системные функции.

6) pointer хранит адрес. по этому адресу можно пойти и взять значение переменной, при этом неважно какого она типа. там, например может быть массив.

7) @ - берет адрес переменной ^ - обозначение, что это указатель или что это разыменование

пример: var a : ^integer; // указатель на integer; b : integer; begin a : = @b; b : = a^ + 2; //то же самое, что b : = b + 2; end.

Реши свою проблему, спроси otvet5GPT

  • Быстро
    Мгновенный ответ на твой вопрос
  • Точно
    Бот обладает знаниями во всех сферах
  • Бесплатно
    Задай вопрос и получи ответ бесплатно

Популярно: Информатика

Caktus Image

Есть вопросы?

  • Как otvet5GPT работает?

    otvet5GPT использует большую языковую модель вместе с базой данных GPT для обеспечения высококачественных образовательных результатов. otvet5GPT действует как доступный академический ресурс вне класса.
  • Сколько это стоит?

    Проект находиться на стадии тестирования и все услуги бесплатны.
  • Могу ли я использовать otvet5GPT в школе?

    Конечно! Нейросеть может помочь вам делать конспекты лекций, придумывать идеи в классе и многое другое!
  • В чем отличия от ChatGPT?

    otvet5GPT черпает академические источники из собственной базы данных и предназначен специально для студентов. otvet5GPT также адаптируется к вашему стилю письма, предоставляя ряд образовательных инструментов, предназначенных для улучшения обучения.

Подпишись на наш телеграмм канал

GTP TOP NEWS