Есть ответ 👍

Написать программу на си ! : дана квадратная матрица. найти сумму четных элементов над побочной диагональю.

118
419
Посмотреть ответы 2

Ответы на вопрос:


что-то типа этого:

const n = 8, m = 8; var        a: array[1..n,1..m] of integer;       i, j, sum, product: integer;       isnotnull: boolean; begin      randomize;       writeln('случайная матрица: ');       for i: =1 to n do begin              for j: =1 to m do begin                      a[i,j] : = random(51) - 25;                       write(a[i,j]: 5);               end;               writeln;       end;       sum : = 0;       for i: =1 to n do              if a[i,n-i+1] < 0 then                      sum : = sum + a[i,n-i+1];       writeln('сумма отрицательных элементов побочной диагонали = ', sum);       product : = 1;       isnotnull : = false;       for i: =1 to n-1 do              for j: =2 to n do                      if (j > i) and (a[i,j] < > 0) then begin                              isnotnull : = true;                               product : = product * a[i,j];                       end;       if isnotnull              writeln('произведение ненулевых элементов в области выше главной диагонали = ', product)      else              writeln('ненулевых элементов в области выше главной диагонали нет.', product);       readln; end.


Не понимаю прости,так бы с удовольствием

Реши свою проблему, спроси otvet5GPT

  • Быстро
    Мгновенный ответ на твой вопрос
  • Точно
    Бот обладает знаниями во всех сферах
  • Бесплатно
    Задай вопрос и получи ответ бесплатно

Популярно: Информатика

Caktus Image

Есть вопросы?

  • Как otvet5GPT работает?

    otvet5GPT использует большую языковую модель вместе с базой данных GPT для обеспечения высококачественных образовательных результатов. otvet5GPT действует как доступный академический ресурс вне класса.
  • Сколько это стоит?

    Проект находиться на стадии тестирования и все услуги бесплатны.
  • Могу ли я использовать otvet5GPT в школе?

    Конечно! Нейросеть может помочь вам делать конспекты лекций, придумывать идеи в классе и многое другое!
  • В чем отличия от ChatGPT?

    otvet5GPT черпает академические источники из собственной базы данных и предназначен специально для студентов. otvet5GPT также адаптируется к вашему стилю письма, предоставляя ряд образовательных инструментов, предназначенных для улучшения обучения.

Подпишись на наш телеграмм канал

GTP TOP NEWS