Есть ответ 👍

(pascal)составить программу, которая определяет встречаются ли в значении строковой величины два подряд идущих одинаковых символа

275
474
Посмотреть ответы 2

Ответы на вопрос:


// pascalabc.net 3.2, сборка 1353 от 27.11.2016 // внимание! если программа не работает, обновите версию! begin   var s: =readlnstring('-> ');   var c: =s[1];   for var i: =2 to s.length do       if s[i]=c then begin writeln(c,' - повторяющийся символ'); exit end       else c: =s[i];   writeln('повторяющихся символов нет') end. пример -> переезд е - повторяющийся символ
masha091115
4,6(82 оценок)

ответ:

⁻b∧(avb)

a b ⁻b avb   ⁻b∧(avb)

0   0   1   0         0

0   1   0   1           0

1   0   1   1           1

1   1   0   0         0

объяснение:

& - умножение = конъюнкция.

1 - сложение = дизъюнкция.

по картинке смотришь с конца.

в конце умножение, сразу ставим знак:

дальше смотрим по верхней линии от & идёт ⁻b, дополняем:

⁻b∧

по другой линии от & идёт к сумме b и a:

⁻b∧(avb)

таблица истинности составляется так:

- сначала выписываешь одиночные элементы - это а и в. их значение нужно запомнить. у а - это половина 0, половина 1, а у в это повторяющееся 01 при 4 строках и повторяющееся 011 при 6 строках.

имеем:

a b

0   0

0   1

1   0

1   1

- затем добавляем отрицание в. оно меняет значение на противоположное. имеем:

a b   ⁻b

0   0   1

0   1     0

1   0   1

1   1     0

- потом добавляем дизъюнкцию, так как она в скобках. дизъюнкция = или. следовательно, чтобы получилось 1, то один из элементов должен быть 1. имеем:

a b ⁻b   avb

0   0     1     0

0   1   0     1

1   0     1     1

1     1   0     0

- и в конце конъюнкция = и. то есть чтобы получилось 1, все элементы должны быть 1. имеем:

a b ⁻b avb   ⁻b∧(avb)

0   0   1   0         0

0   1   0   1           0

1   0   1   1           1

1   1   0   0         0

Реши свою проблему, спроси otvet5GPT

  • Быстро
    Мгновенный ответ на твой вопрос
  • Точно
    Бот обладает знаниями во всех сферах
  • Бесплатно
    Задай вопрос и получи ответ бесплатно

Популярно: Информатика

Caktus Image

Есть вопросы?

  • Как otvet5GPT работает?

    otvet5GPT использует большую языковую модель вместе с базой данных GPT для обеспечения высококачественных образовательных результатов. otvet5GPT действует как доступный академический ресурс вне класса.
  • Сколько это стоит?

    Проект находиться на стадии тестирования и все услуги бесплатны.
  • Могу ли я использовать otvet5GPT в школе?

    Конечно! Нейросеть может помочь вам делать конспекты лекций, придумывать идеи в классе и многое другое!
  • В чем отличия от ChatGPT?

    otvet5GPT черпает академические источники из собственной базы данных и предназначен специально для студентов. otvet5GPT также адаптируется к вашему стилю письма, предоставляя ряд образовательных инструментов, предназначенных для улучшения обучения.

Подпишись на наш телеграмм канал

GTP TOP NEWS