Есть ответ 👍

Составить программу на паскале. имеется целочисленный массив, состоящий из 10 элем-тов. а) найти сумму первых 5 элементов; б) найти сумму чётных элементов стоящих на чётных позициях.

242
459
Посмотреть ответы 2

Ответы на вопрос:


Вцикле от 1 до 10 вводим i-тый элемент массива. сразу в этом же цикле проверяем два условия: 1) если i < 6 то прибавляем этот элемент к сумме1 2) если i чётное и элемент чётный прибавляем его к сумме2. с телефона не выделяются абзацы, поэтому сори за вид.  program zzz;   var s1, s2: integer; x: boolean; var i: byte; var m: array[1..10] of integer;   begin  s1: =0; s2: =0;   for i: =1 to 10 do begin  writeln ('введите ',i,'-е число массива');   readln (m[i]);   if i< =5 then s1: =s1+m[i];   if ((i mod 2)=0) and ((m[i] mod 2)=0)then s2: =s2+m[i];   end;   writeln ('сумма первых 5 элементов = ',s1); writeln ('сумма чётных элементов стоящих на чётных позициях = ',s2); end.

Вдвоичной системе исчисления 1+1=10 (ответ: b)

Реши свою проблему, спроси otvet5GPT

  • Быстро
    Мгновенный ответ на твой вопрос
  • Точно
    Бот обладает знаниями во всех сферах
  • Бесплатно
    Задай вопрос и получи ответ бесплатно

Популярно: Информатика

Caktus Image

Есть вопросы?

  • Как otvet5GPT работает?

    otvet5GPT использует большую языковую модель вместе с базой данных GPT для обеспечения высококачественных образовательных результатов. otvet5GPT действует как доступный академический ресурс вне класса.
  • Сколько это стоит?

    Проект находиться на стадии тестирования и все услуги бесплатны.
  • Могу ли я использовать otvet5GPT в школе?

    Конечно! Нейросеть может помочь вам делать конспекты лекций, придумывать идеи в классе и многое другое!
  • В чем отличия от ChatGPT?

    otvet5GPT черпает академические источники из собственной базы данных и предназначен специально для студентов. otvet5GPT также адаптируется к вашему стилю письма, предоставляя ряд образовательных инструментов, предназначенных для улучшения обучения.

Подпишись на наш телеграмм канал

GTP TOP NEWS