Есть ответ 👍

Нужна программа на pascalabc, кто может . билет считается счастливым, если в его n-значном номере сумма первых [n/2] цифр равна сумме [n/2] последних цифр (при нечетном n центральная цифра в “проверке на счастье” не участвует и может быть любой). подсчитайте число счастливых билетов с различными n-значными номерами (ведущие нули в номерах возможны, но номера, состоящего из одних нулей, не существует). входные данные на вход программе подается натуральное число n < 16. выходные данные выведите количество n-значных счастливых билетов.

198
386
Посмотреть ответы 2

Ответы на вопрос:

Maia55444
4,4(12 оценок)

Var   a: array [0..8,0..80] of int64;   i,j,k,n,m: integer;   s: int64; begin   read(n);   m : = n div 2 * 10;   for i : = 0 to n div 2 do   for j : = 0 to m do     a[i,j] : = 0;   a[0,0] : = 1;   for i : = 1 to n div 2 do   for j : = 0 to m do   for k : = 0 to 9 do   if j - k > = 0 then   a[i,j] : = a[i,j] + a[i-1,j-k];   k : = n div 2;   s : = 0;   for i : = 0 to m do   s : = s + sqr(a[k,i]);   if n mod 2 < > 0 then   s : = s * 10;   s : = s - 1;   write(s); end.

A=9 c=12 ну вообщем как то так

Реши свою проблему, спроси otvet5GPT

  • Быстро
    Мгновенный ответ на твой вопрос
  • Точно
    Бот обладает знаниями во всех сферах
  • Бесплатно
    Задай вопрос и получи ответ бесплатно

Популярно: Информатика

Caktus Image

Есть вопросы?

  • Как otvet5GPT работает?

    otvet5GPT использует большую языковую модель вместе с базой данных GPT для обеспечения высококачественных образовательных результатов. otvet5GPT действует как доступный академический ресурс вне класса.
  • Сколько это стоит?

    Проект находиться на стадии тестирования и все услуги бесплатны.
  • Могу ли я использовать otvet5GPT в школе?

    Конечно! Нейросеть может помочь вам делать конспекты лекций, придумывать идеи в классе и многое другое!
  • В чем отличия от ChatGPT?

    otvet5GPT черпает академические источники из собственной базы данных и предназначен специально для студентов. otvet5GPT также адаптируется к вашему стилю письма, предоставляя ряд образовательных инструментов, предназначенных для улучшения обучения.

Подпишись на наш телеграмм канал

GTP TOP NEWS