Есть ответ 👍

Напишите программу построение светофора в паскале

250
429
Посмотреть ответы 3

Ответы на вопрос:


uses graphabc, crt;  

var klavisha: char; begin  maximizewindow;   rectangle(600,100,1200,1000);   circle(900,250,100);   circle(900,500,100);   circle(900,750,100);   repeat    klavisha: =readkey;     circle(900,250,100);     circle(900,500,100);     circle(900,750,100);     if klavisha='1' then floodfill(900,250,clred);     redraw;     if klavisha='2' then floodfill(900,500,clyellow);     redraw;     if klavisha='3' then floodfill(900,750,clgreen);     redraw;   until 9> 10; end.

среда разработки pascalabc, свет на светофоре переключать на 1, 2 и 3 соответственно.


var   timeinsec: integer; // время в секундах   color, s, m, h: byte; begin   h : = 4; //часы   m : = 5; //минуты   s : = 23; //секунды

  timeinsec : = h * 3600 + m * 60 + s; //перевод времени в секунды   color : = (timeinsec div 10) mod 3; {целочисленно делим на 10, чтобы узнать сколько раз светофор изменил цвет}   {потом находим остаток деления на 3(количество цветов), чтобы узнать какой сейчас    цвет}   case color of //вывод ответа       0: writeln('горит зеленый свет'); //0 - это зеленый свет       1: writeln('горит желтый свет'); //1 - это желтый свет       2: writeln('горит красный свет'); //2 - это крсный свет   end; end.


ответ:достоинства растровой графики хорошое качество файлов. Недостатки они очень много занимают места. Достоинства векторной графики файлы по размеру маленькие. Недостаток их тяжело создавать.

Реши свою проблему, спроси otvet5GPT

  • Быстро
    Мгновенный ответ на твой вопрос
  • Точно
    Бот обладает знаниями во всех сферах
  • Бесплатно
    Задай вопрос и получи ответ бесплатно

Популярно: Информатика

Caktus Image

Есть вопросы?

  • Как otvet5GPT работает?

    otvet5GPT использует большую языковую модель вместе с базой данных GPT для обеспечения высококачественных образовательных результатов. otvet5GPT действует как доступный академический ресурс вне класса.
  • Сколько это стоит?

    Проект находиться на стадии тестирования и все услуги бесплатны.
  • Могу ли я использовать otvet5GPT в школе?

    Конечно! Нейросеть может помочь вам делать конспекты лекций, придумывать идеи в классе и многое другое!
  • В чем отличия от ChatGPT?

    otvet5GPT черпает академические источники из собственной базы данных и предназначен специально для студентов. otvet5GPT также адаптируется к вашему стилю письма, предоставляя ряд образовательных инструментов, предназначенных для улучшения обучения.

Подпишись на наш телеграмм канал

GTP TOP NEWS