Есть ответ 👍

Нужно решение буду завтра итоговая контрольная: дан массив чисел d[i],в котором 7 элементов.найти сумму четных элементов массива,и вычеслить среднее арифметическое всех элементов массива. буду признателен, пишем на паскале, если можно напишите программу, или скиньте скрин! жду

179
398
Посмотреть ответы 2

Ответы на вопрос:

mrdruss
4,5(28 оценок)

Const n = 7; var a: array [1..n] of integer; i, m0, m1: integer;   begin   m0: =0; m1: =0;   writeln('массив --> ');   for i: = 1 to n do readln(a[i]);     for i: = 1 to n do begin     m0: =m0+a[i];     if a[i] mod 2 = 0 then m1: = m1+a[i];   end;   writeln('cумма четных элементов массива: ',m1);   writeln('cреднее арифметическое всех элементов массива: ',m0/n); end.

24 бита  ×   800  ×   600 = 11 520 000 бит = 1 440 000 байт

Реши свою проблему, спроси otvet5GPT

  • Быстро
    Мгновенный ответ на твой вопрос
  • Точно
    Бот обладает знаниями во всех сферах
  • Бесплатно
    Задай вопрос и получи ответ бесплатно

Популярно: Информатика

Caktus Image

Есть вопросы?

  • Как otvet5GPT работает?

    otvet5GPT использует большую языковую модель вместе с базой данных GPT для обеспечения высококачественных образовательных результатов. otvet5GPT действует как доступный академический ресурс вне класса.
  • Сколько это стоит?

    Проект находиться на стадии тестирования и все услуги бесплатны.
  • Могу ли я использовать otvet5GPT в школе?

    Конечно! Нейросеть может помочь вам делать конспекты лекций, придумывать идеи в классе и многое другое!
  • В чем отличия от ChatGPT?

    otvet5GPT черпает академические источники из собственной базы данных и предназначен специально для студентов. otvet5GPT также адаптируется к вашему стилю письма, предоставляя ряд образовательных инструментов, предназначенных для улучшения обучения.

Подпишись на наш телеграмм канал

GTP TOP NEWS