Есть ответ 👍

Напишите программу в паскале abc, которую вводим последовательность целых чисел заканчивающуюся нулем и определяет верно ли что введеные элементы чередуют знаки, например (2, -2, 3, -3, 4, -4, 5, -5: да знаки чередуются) не используя масивов. либо объясните алгоритм действий

166
299
Посмотреть ответы 2

Ответы на вопрос:

nastia295
4,4(28 оценок)

Program lol(input, output); var b, a, a1: integer; begin a: =1; b: =0; a1: =-1; repeat begin read (a); if (a/)*a))=(a1/a1) then b: =b+1; if a=0 then break; read (a1); if a < > (-1)*a1 then b: =b+1; end until (a=0) or (a1=0); if b> 1 then writeln ('последовательность не верна') else writeln ('последовательность верна'); end.
Fulfevgen
4,4(91 оценок)

Первую букву можно выбрать десятью способами, вторую - 33-мя, третюю тоже 33-мя. четвертая и пятая при этом детерминированны и равны второй и первой соответственно. итого: 10*33*33 = 10890

Реши свою проблему, спроси otvet5GPT

  • Быстро
    Мгновенный ответ на твой вопрос
  • Точно
    Бот обладает знаниями во всех сферах
  • Бесплатно
    Задай вопрос и получи ответ бесплатно

Популярно: Информатика

Caktus Image

Есть вопросы?

  • Как otvet5GPT работает?

    otvet5GPT использует большую языковую модель вместе с базой данных GPT для обеспечения высококачественных образовательных результатов. otvet5GPT действует как доступный академический ресурс вне класса.
  • Сколько это стоит?

    Проект находиться на стадии тестирования и все услуги бесплатны.
  • Могу ли я использовать otvet5GPT в школе?

    Конечно! Нейросеть может помочь вам делать конспекты лекций, придумывать идеи в классе и многое другое!
  • В чем отличия от ChatGPT?

    otvet5GPT черпает академические источники из собственной базы данных и предназначен специально для студентов. otvet5GPT также адаптируется к вашему стилю письма, предоставляя ряд образовательных инструментов, предназначенных для улучшения обучения.

Подпишись на наш телеграмм канал

GTP TOP NEWS