Есть ответ 👍

Ядолжна написать 6 лабораторных написать программу на паскале. дана матрица. вычислить среднее арифметическое четных элементов главной диагонали.

164
210
Посмотреть ответы 2

Ответы на вопрос:


// pascalabc.net 3.1, сборка 1230 от 27.04.2016 begin   var n: =readinteger('n=');   var a: =matrixrandom(n,n,10,99);   var s: =0;   var k: =0;   for var i: =0 to n-1 do begin       for var j: =0 to n-1 do print(a[i,j]);       writeln;       if a[i,i].iseven then begin s+=a[i,i]; inc(k) end;       end;   if k> 0 then writeln('s=',s/k: 0: 2)   else writeln('на главной диагонали нет четных элементов') end. тестовое решение n= 8 63 13 33 90 25 21 87 91 88 88 48 13 30 59 81 27 73 23 76 77 52 19 33 97 53 87 13 74 17 35 61 70 77 96 51 61 82 33 63 22 39 88 84 54 88 73 74 69 76 26 69 14 45 80 70 54 80 36 47 38 18 22 84 62 s=75.33

15: 2 = 7, остаток 1 7: 2 =  3, остаток 1 3: 2 = 1, остаток 1 1: 2 = 0, остаток 1 выписываем остатки в обратном порядке: 15(10) = 1111(2)

Реши свою проблему, спроси otvet5GPT

  • Быстро
    Мгновенный ответ на твой вопрос
  • Точно
    Бот обладает знаниями во всех сферах
  • Бесплатно
    Задай вопрос и получи ответ бесплатно

Популярно: Информатика

Caktus Image

Есть вопросы?

  • Как otvet5GPT работает?

    otvet5GPT использует большую языковую модель вместе с базой данных GPT для обеспечения высококачественных образовательных результатов. otvet5GPT действует как доступный академический ресурс вне класса.
  • Сколько это стоит?

    Проект находиться на стадии тестирования и все услуги бесплатны.
  • Могу ли я использовать otvet5GPT в школе?

    Конечно! Нейросеть может помочь вам делать конспекты лекций, придумывать идеи в классе и многое другое!
  • В чем отличия от ChatGPT?

    otvet5GPT черпает академические источники из собственной базы данных и предназначен специально для студентов. otvet5GPT также адаптируется к вашему стилю письма, предоставляя ряд образовательных инструментов, предназначенных для улучшения обучения.

Подпишись на наш телеграмм канал

GTP TOP NEWS