Есть ответ 👍

Нужно написать программу, где в матрице будут по порядку числа от 1 до 30

277
442
Посмотреть ответы 2

Ответы на вопрос:

CorrupteD
4,4(44 оценок)

Так как в идет речь о матрице, то возможные варианты такой матрицы (исключаем 1х30 и 30х1): 2х15 3х10 5х6 далее повторения (меняются столбцы и строки) 6х5 10х3 15х2 попробуем написать программу, которая создает нужную матрицу  по первому числу (количество строк) и заполняет ее: //pascalabc.net (версия 3.1, сборка 1210 от 29.03.2016) var   a: array[,] of integer;   n,m,i,j,k: integer; begin   k: =1;   write('введите количество строк (одно число из 2,3,5,6,10,15) ');   readln(n); m: =30 div n;   a: =new integer[n,m];   for i: =0 to n-1 do begin       for j: =0 to m-1 do begin         a[i,j]: =k; k: =k+1;         write(a[i,j]: 3);     end;     writeln;   end; end. тест №1 введите количество строк 5   1  2  3  4  5  6   7  8  9 10 11 12   13 14 15 16 17 18   19 20 21 22 23 24   25 26 27 28 29 30 тест №2 введите количество строк 3   1  2  3  4  5  6  7  8  9 10   11 12 13 14 15 16 17 18 19 20   21 22 23 24 25 26 27 28 29 30
cat497
4,8(63 оценок)

Шар-шарф , дар-удар стол-не знаю арка-марка оса-коса тело-тепло

Реши свою проблему, спроси otvet5GPT

  • Быстро
    Мгновенный ответ на твой вопрос
  • Точно
    Бот обладает знаниями во всех сферах
  • Бесплатно
    Задай вопрос и получи ответ бесплатно

Популярно: Информатика

Caktus Image

Есть вопросы?

  • Как otvet5GPT работает?

    otvet5GPT использует большую языковую модель вместе с базой данных GPT для обеспечения высококачественных образовательных результатов. otvet5GPT действует как доступный академический ресурс вне класса.
  • Сколько это стоит?

    Проект находиться на стадии тестирования и все услуги бесплатны.
  • Могу ли я использовать otvet5GPT в школе?

    Конечно! Нейросеть может помочь вам делать конспекты лекций, придумывать идеи в классе и многое другое!
  • В чем отличия от ChatGPT?

    otvet5GPT черпает академические источники из собственной базы данных и предназначен специально для студентов. otvet5GPT также адаптируется к вашему стилю письма, предоставляя ряд образовательных инструментов, предназначенных для улучшения обучения.

Подпишись на наш телеграмм канал

GTP TOP NEWS