Есть ответ 👍

Алгоритм вычисления значения функции f(n), где n – натуральное число, задан следующими соотношениями: f(0) = 1, f(1) = 1 f(n) = f(n–1)*f(n-2)+2, при n > 1 чему равно значение функции f(5)? в ответе запишите только целое число.

127
422
Посмотреть ответы 2

Ответы на вопрос:


1. ручная прокрутка алгоритма f₀ = 1; f₁ = 1; f₂ = f₁×f₀+2 = 1×1+2=1+2 = 3; f₃ = f₂×f₁+2 = 3×1+2 = 3+2 = 5; f₄ = f₃×f₂+2 = 5×3+2 = 15+2 = 17; f₅ = f₄×f₃+2 = 17×5+2 = 85+2 = 87 ответ: 87 2. программное решение с использованием итерации // pascalabc.net 3.1, сборка 1204 от 24.03.2016 begin   var f: array[0..5] of integer;   f[0]: =1; f[1]: =1;   for var i: =2 to 5 do f[i]: =f[i-1]*f[i-2]+2;   writeln(f[5]) end. результат выполнения программы 87 3. программное решение с использованием рекурсии // pascalabc.net 3.1, сборка 1204 от 24.03.2016 function f(n: integer): integer; begin   if n< 2 then result: =1   else result: =f(n-1)*f(n-2)+2 end; begin   writeln(f(5)) end. результат выполнения программы 87
asiali1
4,5(24 оценок)

Вроде

Вход

Заполнение

Код с картинки

Создать почту

Реши свою проблему, спроси otvet5GPT

  • Быстро
    Мгновенный ответ на твой вопрос
  • Точно
    Бот обладает знаниями во всех сферах
  • Бесплатно
    Задай вопрос и получи ответ бесплатно

Популярно: Информатика

Caktus Image

Есть вопросы?

  • Как otvet5GPT работает?

    otvet5GPT использует большую языковую модель вместе с базой данных GPT для обеспечения высококачественных образовательных результатов. otvet5GPT действует как доступный академический ресурс вне класса.
  • Сколько это стоит?

    Проект находиться на стадии тестирования и все услуги бесплатны.
  • Могу ли я использовать otvet5GPT в школе?

    Конечно! Нейросеть может помочь вам делать конспекты лекций, придумывать идеи в классе и многое другое!
  • В чем отличия от ChatGPT?

    otvet5GPT черпает академические источники из собственной базы данных и предназначен специально для студентов. otvet5GPT также адаптируется к вашему стилю письма, предоставляя ряд образовательных инструментов, предназначенных для улучшения обучения.

Подпишись на наш телеграмм канал

GTP TOP NEWS